Close

Pontiac Bonneville Questions

Get answers to questions about your Pontiac Bonneville at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
633
questions

ir will take gas then it won't over and over again until I let it rest and then it's fine again. Could this b a cooling sensor or the fuel pump?? Please help

It runs just fine until u drive it for about an hr than with gas pedal pushed down it will take gas than it won't. Could this b the fuel pump

My 1992 Bonneville SE is stalling after 10 minutes or less then won't restart for about an hour. Initially it wouldn't put up a trouble code in the computer, but finally kept it running long enough to set up 2 codes. 31 and 41. The PNP switch has been bad ever since I owned the car, but the 41 code suggests the camshaft sensor circuit or cylinder select in the ECM. I am assuming it is the camshaft sensor since in the code reader manual, a 31 can also refer to the camshaft sensor circuit. By pulling the gear shift down to drive and increasing the RPMs, I got the car to keep running past the sputtering and it continued to run fine afterward until shut down and the check engine light appeared and revealed the codes. The engine would not restart until it had cooled down for about an hour. When it does this, I have checked and noted that there is no spark from any of the ignition coils until it has cooled. I have cooled the ignition coils with alcohol, but still they do not set off a spark until the engine itself has cooled. Any one else experience a problem similar to this and if so, what causes it. Engine runs great when running and has always been dependable until just 2 weeks ago when this problem surfaced.

Just bought the car used. The first day, it ran fine. After a couple days, it started idlin' then die. Id have to wait a while for it to start back up. The time varies, also. Sometimes it will last bout am hour, then next day it wont last a few minutes. The MAP sensor has been replaced. The crankshaft/camshaft sensor is also good. Please, I need help.

I was told there is a door module where can I get one at a fair price

Happens after car is driven for a while. It restarts after it stalls and runs awhile until it happens again. When it occurs interior lights come on. It happens both when driving or sitting at light. Car needs to be driven for it to happen. When it stalls everything shuts down. meters act erratically , rpm's up and down, battery gauge drops, until complete stall when all shuts down.

Mass air fault came up rr new ran worse got another new ran bad also put old back in and drives fine except shuts down at stops any thoughts cause code keeps saying mass air flow sensor

changed fuel pump and filter same problem

cold air do not come on then it will blow hot,,an my defrost will stay an it will not change to other vents

I was leaving for work this morning and the power to the car just quit. the engine is running but when i press the gass pedal rpm goes up but nothing. been outside testing it the transmission fluid is fine and oil. the engine is running normally no sounds except basic engine noises, however when i put it into gear it sounds like the engine is trying to stall out, I watch the battery volt meter go back and forth and not sure what could be causing it. again when in park or neutral the engine runs fine but when i put it into gear it sounds like it trying to quit.

they say some type of bar under the front carriage broke

After turning the ignition10 to 13 times the car will stay on and when im driving the car sometimes it will stall and when im driving it hesitates I had a diagnostic abd it says its the computer can u tell me if this would be the reason im having this problem how much is this computer n can I install it please let me know thank you

The manual said to wait 3 minutes when car won't start.
That part works but why does this happen? Is there a sensor?

I have tried removing the Glove Box but all I find is a large bracket that when the bolts are removed will not come out.

sometimes it works just fine but other times it won't come on at all. once during the winter it came on after about 20 minutes of driving but I had just hit a bump in the road, don't know if that had anything to do with it. any suggestions ?

All actuators work, all vents blow just fine, ac is fully charged.. when I shut the air off for a second as it quits blowing the air gets cold. When the system is shut off, I can frequently hear what sound like a door or Actuator still moving but just a fraction of an inch and back. I've watched it but when turn the system on it moves fine. I don't think that has anything to do with it unless the door is stuck I guess. So hard to explain.

I drained out and replaces all rear lights and don't know what to try next...

My 96 bonneville is misfireing around town runs great on interstate we have replaced coil pack, and brain ,alternator, plugs, and wires, fuel filter, it's backfirieing ,popping ,jerking when Gas is pressed.what could it be causing this problem.thank you.

The speed can be adjusted but they won't shut off

I started having this issue about a month ago. The car cut off as I was parking, I thought I had cut the wheel to much but when I came back out it still would not start. I tried jumping it, replaced the fuel filter and pump. Each time a repair has been made it starts and will run for the duration the car is turned on but if you turn it off and it sits for a few hours, it will not start again. I think I failed to mention all my problems started when the brakes went bad and I started getting the brake warning on the dash. I had that fixed and now this issue. Can someone please help, it's the only vehicle I have and I need to get back and forth to work.

I started having this issue about a month ago. The car cut off as I was parking, I thought I had cut the wheel to much but when I came back out it still would not start. I tried jumping it, replaced the fuel filter and pump. Each time a repair has been made it starts and will run for the duration the car is turned on but if you turn it off and it sits for a few hours, it will not start again. I think I failed to mention all my problems started when the brakes went bad and I started getting the brake warning on the dash. I had that fixed and now this issue. Can someone please help, it's the only vehicle I have and I need to get back and forth to work.

I read my manuel and the parking brake has been release but the light stays on

I've had several people look at it. Not the oil, not a piston. Two people said could be a broke flywheel but my car still starts and drives. They also said the noise is not coming from the engine. The other two people said it's the motor and I'm out of a car. Any ideas what this could be?