Close

Mercury Sable Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
1,051
questions
it idle to fast sometimes while driving
The lights that illuminate the mph, rmps, temperature are light only on half of the dash panel. Also the climate control knobs are not illumating anymore. Can you tell me the location of the box? What are they labeled as? Are they 10 amp or 15 amp? I'm assuming it's under the dashboard.
I'm trying to tow this car for a friend it blocking the garage door
I was told by a garage that the "water inlet pipe/hose is what needed to be changed on this car. It appears to me to be the bottom radiator hose. (same thing ?)
It doesn't look like an easy job
First time I have encountered this big a spark. Will it burn

What seems to make the problem better or worse? Too scared to connect
Id bought a 97 sable but was never given the door code. Where can i find the factory code, and if a personal code was programmed how could i replace with factory code?
fluid & filter replaced/codes reed bad trany selector switch sensor/wont shift pass 3rd gear/AX4N trany.
What seems to make the problem better or worse? It's worse when engine warm
Installed new alternator. Cleaned terminals, grounds, new starter,voltage regulator from older ford f150 turned on got 14 reading volts or amps,? Drove 50 miles at stop light smoke pulled over put out fire. Negative ground wires fried .positive wire look untouched. Haven,t started repairs
What seems to make the problem better or worse? Just caught on fire, I did turn on the vent fan
How long have you had this problem? One day
how many hours labor should I expect to pay for this
The tranny fluid spewed out of the dipstick spout. I added more fluid and noticed a burnt smell on the dip stick. Now it just revvs when i try to accelerate past 15 mph.
it also when revved it gets pre-detonation.
The trouble codes that I pulled are saying that theres a misfire in 2 cylinders. Idk for some reaso its got me stumped. The problem is at idle not while driving. Anyone have any idea
My blower motor for my air flow works bit no air comes out the vents or defrost
The fans does worknunless the air and it is leaking water but not on the ground, my nephew said that it's missing the radiator
Transmission seems as if it tries to slip when shifting into 2nd. Owner says that the fluid and filter has never been changed, at least in the last 100,000 miles. Wandering if the fluid and filter could be the possible cause or if there are any known similar issues for this model?
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.