Close

Mercedes-Benz S430 Questions

Get answers to questions about your Mercedes-Benz S430 at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
368
questions

chirping sound

Trunk won't open with remote or button on the door. The air seems to have leaked out the pushes the trunk up. What part do I need to buy?

a mechanic charged me $1600 to fix my AC that was not working my SRS light that was on and now the problem is re occuring. when I start the car many times the AC will not come on,the SRS light is on,the window locks will not work,the windows will not go down and my turn signals will not work. I will have to start the car 5 to 7 or more different times before everything starts working and now the mechanic is telling me it's the control board. What are my options?

High beam work driving lights work but no low beam

car will not rise it there manual shock for this model?

Sound stopped by itself, is there a fuse for the sound?

The car seat we are using has traditional lap belt "feed" and an anchor for the forward-back motion. I cannot locate the anchor to attach to.

When the outside temperature is over 80 or so degrees the drivers side gets warm while driving in sunlight. But it works fine at stops for lights or stop signs. it also works fine after sunset.

When I shut off my car last night, I didn't realize I hadn't turned the igntion all the way off before pulling out the key. The battery was dead this morning. Also, I don't have the key that folds into the remote, I just have the spare so I couldn't get into the car. I had to get a locksmith to open it.

When I got in it, I put the key in the ignition and realized it was only part way turned off, so I turned in all the way off. Now it will not move to the "on" position at all.

So the battery is dead, I'm getting a jump, but if my key won't turn the ignition what do I do? Is there a reset? Or will getting my battery charged allow it to work?

Sus. pump come's on but car will not rise up what could be the problem?

Where is the fuse box located that has the fuses associated with the a/c system?

I have a 2004 Mercedes Benz S430, the battery was dead, I jump started, I went out but the next day I tried to started but it won't start, trying to jump start it nothing happen. I took the battery to the store that I'd bought it from, they charge it, come home, it would not start. It unlock the doors but the folded mirrors will not open when I open the doors, put the key in the ignition it would not turn or start the car. I change the remote battery, I still have the same problem. the car would not crank. Please help!!

We have looked and pulled one out but they still dont cone on

2 things wrong 1st my car will not go into park. the stick shift will engage every other position but stops before park.

2nd problem I'm losing coolant on every drive temperature seems high

need to know what the problem is

I can't get my navigation to come on when I select navi from the panel. Everything works but I can't see nothing on the screen.

how much to repair

I found the panel near passenger foot but which number is for cd changer

everytime i start my car up the entrance light comes on. And when i turn it off the driver side drops down.

my Mercedes has been setting in the garage for a few months and the battery is dead how do I jump it off?

Where is the access to the left turn signal lamp and
do I need a special tool to replace lamp???

Thank your for reading my concern, and question.
This is what I know so far:
I purchased this card about (3) months ago and the car would lose air pressure in the front if i did not drive the car every day. I would let it sit for (3-4) days, and the car would be low in the front. Im unsure if this is normal, but, when I would start the card, and would rise with no problem. Even if i did not push the button on... but turn car on, the front would rise.
HOWEVER, last week I turn off the car, and a loud noise was coming from the air suspension pump. Even when the car is off the pump would shake really bad, and make loud noise.
TODAY, it makes no noise, does not shake, and the card wont rise. The car is not low in the back. Only in the front. And the right/passenger side is leaning more to the ground than the driver side. But, the driver side is low too.
i never heard air leaking from anything.
Could this be the air pump, or relay, or failed air shock?

I just replaced the transmission control unit.

are there 3 fuse boxes?. two under the hood-inside the engine compartment, where is the third one if the car has three fuse boxes.

trunk sounds like it is going to open, but will not open remotely from inside the car or with the remote. Trunk only opens with the mechanical key. Also have to push or force down to close the trunk; trunk lid leaves or hangs about 3-4inches gap.

stereo and gps works, but no sound out of speakers. Checked the fuses inside the two fuse boxes under the hood and they are all ok.

What is this? I know the seat belt maybe part of the problem I need more info.

more fuel consumption.

gomy good s430

i had it towed to the deaier and they said bad pump brought it home got new pump and relay still nothing.fuses under hood are good any ideas