Lincoln Continental Questions

Get answers to questions about your Lincoln Continental at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more

I checked the fuse for the rear window defroster, and found it to be OK. About an hour later, I got in the car to go run an errand, and the digital dash was out. I have checked all of the fuses under the dash and in the engine compartment. Ideas?

I went into a store and everything was fine. I came out and the rear of the car had bottomed out. Is there a relay or fuse that could have failed?

The RPM's read about 1500-2000 but engine sounds like it should be reading 3000 RPM's or higher

I charged the battery its getting fuel out of the top of the motor,its charging,its cranking but wont start

During acceleration it chugs

When I push on my breaks they are hard and make the traction sound

I tried removing the shroud so I can do it from above since getting up and down isn't easy for me anymore, but after getting all of the obvious screws, etc removed it's still very secure. If I have to climb underneath I'd like advice so I don't have to get up and down more than necessary....getting too old for this stuff!

Just got the car and code will not work. Suspect the fuse. Any ideas?

What is cost to replace power steering pressure switch?

Part # 19D742 A/C Accumulator Tube Assembly (Suction Line)
for 2001 Lincoln Continental
Where can I find these two parts
Who knows where I can locate these items...Part numbers are Ford Parts

All other power seat functions work fine.

At start up pump starts you hear a click second later another click pump stops. It sounds like the click is the left solinoid opening and closing sounds like right one not opening- changed it same thing. In between clicks left side goes up 1/2".

break lines are rusted & need replaced

wipers only work when I push the wiper fluid button, then they only do 3 sweeps and back down they go. I have to keep pushing the wiper fluid button to get them to come on. nothing happens when I try to turn them on normally. I already checked the fuse and it seems fine. This just started happening about 2 months ago. they worked just fine before that.

earlier i got the code po113