Close

Lexus ES300 Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
896
questions
If you go back to below 35 runs smooth again. Mechanics i spoke with suggested - computer issue, Torque module issue or possibly Altenator issue
I hooked up jumpercables hot on negative and ground on positive and now my car want start .what did I burn up?
Into a es300 1998...Lexus both
My PCV has not been changed in 50,000 miles.
The tire seems to get blisters bumps and bubbles on the outer side of the tread on the front end driver side tire it appears to be leaning in at the very top I guess that would be a toe in our camber out of the out of alignment but the popping sound still makes no sense
my car runs great when outside temp is below 40 degrees
Just purchased the car, hoping it would be a reliable choice, now day 3, I hear a revving sound while in the lower gears, it doesn't happen all the time and didn't happen at all when I test drove it.
Any idea what this might be?
I have had 2 tires on our 2002 ES300 that just won't maintain the correct pressure. I have had it into the tire shop and the stems replaced. The problem has persisted from the old set of tires to the new ones install about 6 months ago. I have heard that others have experienced a similar issue, in particular on a 2003 ES300, same problem. Depending on miles driven we might need to put in more air in two of the tires 2 to 3 times a week. Does any one know of a problem with the Lexus rims having defects that allow air to leak out? Any ideas would be greatly appreciated.
Heating I had the thermostat changed and it ran fine everything work on it and one morning I woke up and went to the store to put gas when I came out there was sugar around my gas tank rim I didn't drop the tank but pulled out the fuel pump from the back seat and scraped out all the sugar that I could and replaced my fuel pump as recommended it ran fine for 2 weeks maybe longer but sometimes in the morning it would stall and when I would be at a light it would feel like it would want to turn off one day it just completely died on me I thought it was low on gas so I added some but still no start I replaced the fuel filter as well as other sensors and fuses I've got some friends to help me out one said it had no spark and another said I had no fuel pressure it's been a month since my car has ran and I only had it since August I'm really hoping to get my car back on the road and will take a knee help or suggestions I can get
Passenger side won't come out. Is it seized in the carrier bearing? If so, then how do I remove the axle...
What could be causing this problem?
I am trying to replace a leaking cv shaft seal on the trasmission
All lights are working fine... except, parking,tail light and side markers...turn signal and break light work fine.... could all these bulbs blow at same time ??
The manual stops at 150K. The car runs well but the dealer tells me I need this service....where do I find what it entails. Thanx
Recently I have replace all 6 coils, plugs, fuel filter, regulator hose, thermostat, replaced my valve cover gasket and the front (small) catalytic converter. Next up is a leaky oil pan gasket and finding a nut for my throttlebody housing which has disappeared magically.

Anyways, my check enine light is no longer on after my recent repairs, but after about 3 weeks of driving it started to chug a bit, now when I sit at idle or when I'm slowly pulling into my garage / parking spot, if I'm not feathering the accelerator the car will shut down. The fuel pump is about 19 months old.
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.