Close

Ford Explorer Questions

Get answers to questions about your Ford Explorer at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
3,307
questions

gauge goes from past full then back to what may be the right level

I put a new oil pump. Spark plugs, crank and cam sensor and oil pressure sensor. Still won't start.

if the coil packs are bad......, will it cause the engine to turn over slow

only seems to surge when going on slight uphills

I have looked on line and have been lied to by 2 Ford dealership(they don't have info). And charge $400 for job
I'm on limited income. This is a safety issue. I have inch and pound torque wrenches, just need a number. If I break glass it's over $800 to replace.

I never got informed about the power steering control module box and it was icy out and it shut down on me I lost all steering and braking didn't work from the ice ended up off of the road the both sides of my car has bumps all along the them along with a cracked windshieldnow that outs hit out my ac wound work they said it was due to damage. And want mbre to shell okie almost a grand to fix out. What should I did?

Was driving n cut off battery light came on first I jump start it n it crank but as soon I take jumper cables off car cut off. First time it ever did this

Have replaced the coil ,wires and plugs. OD off light is on always. 2months ago it started lugging and stalling coming up to a stop unless I down shit. Now it stalls everytime I shift from park or neutral, to Drive.

my 4 wheel drive automatic ford explorer's transmission went out when son tried to smoke the tires on senior day. Got another transmission and installed it. It ran ok for six miles, and now it quit and car will not go into any gear. gear shift works, but car will not go into any gear and will not move at all. motor runs fine. Please help me. What could cause this.

problem occurrs whilie driving

just replaced heads and timing components. starts good, runs down the rd good. idols low and rough. tries to die at idol sometimes

Would like to have a rebuilt engine put in my vehicle.

Or it's leaking for the seal are

new struts and bushings have been installed but still very load banging comeing from front

When the problem occurs is at first startup at my house and every day of the week

I have a 2004 ford explore the oil light came on and it stared tapping so I shut it off and had the oil pump changed now it cranks doesn't want to start

squeeking from right front

Driving less than 15

on low speed turns on bumps in the road

i have had all the sensors replaced and the service engine light is still on.. i was told there is an electrical short..
The radiator is shot and needs replacing

squeeking on bumps and hard turning at low speed sound coming from left front

won't do anything so changed battery now even the lights don't work

On bumps and turns

Lost mynclutc completely so replaced master and slave cylinder still nothing? When I try to bleed them no fluid comes out bleeder screw at all and fluid don't get any lower during bleeding them?

drive along overheats and when it is shut off cools down in a matter of minutes. Might not do it again for month.

JUST NEED TO REPLACE SENSOR
P0405 TO SEE IF SERVICE ENGINE LIGHT
IS FIX. THANKS

drivers controls are not working nor each door controls work on any doors so windows can go down or up.

So I recently got towed..he asked if it was AWD..I specifically told him it was..he put it on dolly with 2 front tires lifted..we drove a few miles and heard loud noise and I turned around and it was smoking..I guess from my bck tires? He then got out and put my my truck on 4 wheels lifted. I thought nothing of it even though but one day my od light kept blinking entire day..it stopped next day..then I notice I can't drive over 55mph on freeway without shaking. Now it can't drive on freeway at all ..when I drove 40mph on freeway it kept going from side to side..I can't drive past 25- 30mph now..I just parked it in driveway before it gets any worse..I tried to take to shop..spent over $700 in total had tie rods replacement but car still the same. Could that tow damaged my rear end ? I don't know what's exactly wrong with my truck.

Cam and crankshaft not synchronized. But live data says it is. What caused this

When it's cold, transmission slips and there is no dipstick to check it.