Close

Ford Aerostar Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
250
questions
Has been running rough for a while. Happened before and I put it in neutral and pushed it forward then in drive then park and it started right up. Then drove 1,00 miles no problem. Each time after sitting a day or two problem returns.
Small amount of air comes through the defrost when any of the positions are on the dial. Can't get A/C to come through the proper vents How do I fix?
Is my engine blown
Oil sending unit seems ok; I apply gas w/ brake to maintain a steady gauge at stops. I have added "no leak" to oil, and it helps for a while. I thought this May be vacuum problem with regulator valve on side of transmission ( an oil diaphragm inside), and have the part, but no tools/ equip to replace it. Before I send it to a shop, I would truly appreciate some insight as to whether this is advisable.
Do I replace the converter in hopes it eliminates the problem or start with something else like to 02 sensor etc. I am female and know nothing about car repair. trying to save money so I can sell this van. Thank you.
With the engine running the temp indicator slowly rises to about the o in the word normal then drops down to cold. This cycle continues throughout the entire trip. Rarely get hot enough to warm the car,
I get a loose feeling clunk when going over bumps and potholes, I have high pitched whine on turn. Thick sludge is present on driveline/ujoint side of diff housing. Previous owner replaced broken trans with rebuilt one from wreaking yard before I purchased it. It shifts smooth but now diff sounds like axle on right is loose and sloppy and wheel is following suit as well can hear clunk at diff housing as well. No axle seal leaks at the wheel bearings can be found by my inspection. What should I do? Have done similar repair on my Toy 4Runner but only replaced bearings and seals with inspection of diff showed low fluid and no metal shavings present in drained fluid.
Even after driving 5 miles the front air system only managed to blow lukewarm air. The engine was at normal operating temperature after a couple miles. What do I need to do to resolve this issue?
tranny problem was working going fine and just failed
To clarify my previous questions, I want to say that 1 time when I was on the frwy, I had to gun it to get on and after that , the engine made some noise. Then , something started bouncing off the ground in the back and making a metal sound on the concrete for a few sec. Esp. when I went over a bridge. It got worse and worse, then the brakes started to lock for a few sec. then release. Lock again and for a few more sec. and then again for a min. and now they won't release.
Should I just junk it or is it be repaired at a cost less than the value of the van?
I didn't get to finish from my earlier question. With frozen brakes, rear end busted, I Have to tow it.
AS the rear end started making noise, the brakes started to freeze up and then release. How much to fix this?
Started after my son replaced the speaker wire, told me that it got coughed somehow when he was pulling it,
Both cables by gas pedal has the plastic adjusting part broken how do I replace it?
both locks mechanism are broken inside, how do i replace them or repair...
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.