Close

Ford Questions

Get answers to questions about your Ford at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
26,915
questions

WHEN PRESSING DOWN ON BRAKE PEDAL THE PEDAL WAS PULSATING AND IT SEEMED HARD TO START

Can i tow 4 wheels down with this vehicle? It is a manual transmission. So if it is in nuetral will it be a problem?

Replaced fuel filter. Replaced fuel pressure sensor to clear code. Only code now is p0463 for fuel gage sensor in tank. Gage hasn't worked in a few years and never had this problem before. Shutter \ stalling happens between 45-60 mph.

my radio would not turn off so i removed the radio and now my my wipers are on and will not switch off

Monitors always take over a month to clear

Low beam light blown need to replace can't find it

Need to replace low beam bulb. Can not find it

The drivers side window doesn't work, but the others do. Everything else seems to be fine. This happened while the car had been driven for about 10 minutes, and parked for about 15mins. The light did come on one day about a week before. But had not been on consistently, And I didn't notice any message prior. Thank you for any help/advice that you can offer.

the diagnostic codes showed miss fire on all cylinders but #2

What's driving down the highway in the car tried to die I had to keep pedaling it to keep it running once I got to where I could stop it would only start and then die start and die wouldn't stay running

Dead no sound. tap starter .starts right up.
May last a day may last a month. Any ideas. Also alot if static thru radio. Can only get 1 close station

Hello..
I Have problem with finding parts for my Ford Probe I 2.2 GT Turbo 1991.
Can somebody help me please.
I need drive shafts and lots of rear axle parts..
I live in Ireland, Galway.
Big respect for this man who help me with Headlights problem..
Thanks Cheers

car showing a po320 code cr is sputtering especially on take off or up hill i have been told the coil pack is probably bad its a 4.0 sohc engine

It's started blowing clouds of white smoke out of exqust & using lots of antifreeze/water & getting hot every 5miles haven to fill reservoir back up also gage is showing HOT & check gage is coming on wen it runs out or gets low of water/antifreeze??? Is it the head gasket blown or what exactly is it??? THANK U,VERY MUCH..

need to where it is located and how to change it I know about the reset button in the truck

P0174,runs rough, looses power, but not always

Just occured today. First time happening..

Yes, before anyone asks, the dual air settings are set properly. I was just rear ended and it was in the body shop for 3 weeks. As far as i know they didn't touch the engine or front of the car but I just picked it up and now it's blowing HOT air out the passenger side?

a/c does not blow out center vents

My E150 losses pressure when driving about 20 minutes feels like it's blocked it takes some time to build power from idle to stop. Every 2 to 3 days I ave to refill radiator?

No foward or reverse

On and now they say the pcm is out and I need a new computer. Did they do somthing wrong when installing my battery to make my computer skrew up?

Sometimes the A/C works properly for a short time after starting the vehicle then you can hear the diverter close and the fan motor keep blowing. What might the problem be?

The light just came on for the first time today. Just the light that is shaped like an engine. How do I interpret and repair these issues? I have an Innova 3030 code reader that does powertrain, chassis and body codes. There are no driving symptoms, the vehicle was getting 39 mpg while the light was on steady for an hour today. I can try to erase the codes.

The air wouldn't go on today. And the don't work either. Help

It goes into the other gears fine but like 30 mph , it has a problem shifting to next gear the RPM's get higher, so I let of the gas and it goes into gear. But later when it needs to downshift out of the gear, it goes in hard. What is wrong wgat do I need to do ?

Advance auto checked my alternator and battery. Told that alternator was bad so I purchased a new alternator. my battery then went dead so I purchased a new battery. When I went back to have the new alternator and battery checked I was told the new alternator was not charging the battery and that it could be an electrical problem. I changed the solenoid switch, voltage regulator and replaced the alternator again. Same problem alternator not charing the battery. I did noticed that the switch to starter cable had a melted burnt spot on it where the cable fits into it. Could this be my problem. Vehicle is 1984 Ford f-150 pickup 302 5.0 liter engine. Please help?

in the engine?

this is an automatic 4x4

I pressed my brakes and felt a vibration with a sound like a thud.