Close

Chevrolet Silverado 3500 Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
Lost pwr shortly after loading trailer (gooseneck type)-reduced max speed to 25.gauges all at normal operating ranges.nothing noticeable wrong. Starrs/runs smooth. Turned off/let sit 30 mins...unhooked trailer-short road test-operated like its "normal". Diesel tanks full. .please help troubleshoot problem
I programed a new key fob earlier in the day and when I went back out to go to the store, about 4 hours later, I had no coolant temp, no cruise control and now I have a P0700 tranny error. I do think the coolant temp is the cause of the tranny error but is it a fuse, thermostat or sending unit?
We got a code P0606, P0336, P2356 and could not reset the codes .... eventually the truck started losing power and then engine failed. Is this the crank shaft sensor or the PCM?
truck was running and daytime running lights were on except for the passenger side which had burned out. When I changed the bulb ( truck still running) the cdaytime running lights stopped working. I have checked the DRL fuse and DRL relay in the fuse panel under the hood. Any other fuse or relay or sensor that would be the issue? Suggestions?
after engine warms up
replaced control head need to reprogram system
The blower works but no warm air. Checked the coolant and is ok.
Passenger side always had problems with warm air blowing when AC on.
What could my problem be? Maybe the thermostat? How can the thermostat be checked?
Thanks, pt
driving fine then lost acceleration and starting making a cracking sound
Terminals clean. Twice the security alarm has went off at 2am. Vehicle was unlocked. Bottom seat heaters have quit. All problems about 6 months ago.
truck throwing a code that its a pressure switch and do no where it is
Not sure if these are all related the heated seats light up when you push the button for one second then go out immediately
You Tube has a few samples of the problem , but no answers!!!
My low fuel light is on. I have replaced the fuel pump in the front tank. I have a full tank in the rear tank and 1/2 full in the front tank.
When I first start the cold engine the Gage goes up then down to E and the light comes on.
I know It's not the fuel pump.
Any idea whats wrong.
AL
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.