Close

Chevrolet Monte Carlo Questions

Get answers to questions about your Chevrolet Monte Carlo at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
946
questions

Transmission is shifting real fast, 1st to overdrive in seconds

it does not over heat, but i lose all accelleration power when it get's noisy. but it only happens intetmently.

the factory paint is very defective. The paint on my car is white and started around december 2016. my car looks like complete trash with giant chipped paint spots all over. Every time i wash my car the hose strips the paimt away. ive never seen any thing like it. This is a manufacture issue. i have a neighbor with the same car as mine and hes having the same problem. will the manufature fix this?

i need to know why there would be low voltage reading going to the abs system

I am trying to find out if I can get a window off any other year Monte Carlo that would fit the same.

Vehicle runs just fine. light blinks then stays on.

Some days it doesn't overheat at all, some days low coolant light flashes between it & Check engine. Constantly adding Coolant & or water. Check Engine light stays on. Car cranks at startup but quits when putting in gear and foot is taken off accelerator. Car has good power runs quiet & smooth, no smoke evident when hot, cools quickly has heat.

Just bought a Monte Carlo 2004 runs great but has a ticking noise constantly

Only after 2 seconds after starting no sounds or anything runs great

turn signal issue both directions blinks twice and stops flasher works fine

My MC has does not blow hot/cold air at all I have tried to blow air through the vents and all other positions. I noticed it use to pop on at random then it just stopped completely. I was told to test the relay first but can't find it. None of the fuses under the hood say blower motor.

Smoke come from the exhaust tail pipe when first turn on engine and even if you let car run for 15 minutes or more. There's no notification light that appears on dash board when this happens.

I HAD THE RADIATOR CHANGED WATER PUMP AND ALTENATOR FIXED AND NOW IT DOESNT WANT TO TURN OVER.JUST RECENTLY.WHEN I DROVE ABOUT 5 MILES IT LOST POWER IN THE BATTERY NOW IT DOESNT TURN OVER UNLESS I PUT MY FOOT ON THE GAS THEN IT CUTS OUT WHEN I TAKE MY FOOT OFF THE GAS.

My volts lite comes on after my car cuts off..i restart it an it shuts down again an wont start until i wait awhile

Is the only gear that want work anymore?

Im trying to locate to where i poor power steering fluid at?

when driving the gauges stop working turn the car off turn it back on the gauges come back on

The leak is coming from the side on the overflow tank side and for some reason the gauge is reading hot after I let the car sit for hours the hand go straight to red

My car won't start sometime

Threads are not damaged no sign of cross thread , so much pressure thought they were gonna snap into . Should i use tap of same size plug thread n run in n out of plug ports . Gd or Bad idea ?? Looks like they have been in motor for some time !!

Threads were not damaged no sign of cross thread , should i use tap of same size n run down plug ports , Good or Bad idea ?? Not to mention will definately use anti seize !

Only when reversing my car or you have the car on park. Is makes a loudifference noise too

it overheats while throwing hot air, then heat stops and it temp goes down to half

I have damage to my hood and can't find a replacement the same year

When I turn on the heat I have a strong gas smell.

my auto shop says I have a oil leak in the top manifold on my Monte Carlo
it not bad but he wants to charge $800.00 to install a new seal. the car has a 139,000 mile on it . it just a work car hail damage etc.. don't want to put that much into it. will it make it worse?? I want to try to get around 200, 000 out it or a little more if I can. if it will work any suggestions on a certain brand? any help will be appreciated. thx

A few weeks ago my signals started making a loud sound like a frying sound, shortly after that all my dash lights, raído lights I mean every light that is in the interior later my car was starting weak so I replaced the car battery, to only end up with my car in the worst posible shape DEAD!, my car is completely dead, checked all the fuses and relays, It seems like there is no juice but they battery is good I took it back to auto one they checked it showed me the readings, anyone with any advise please I welcome it all thank you

What could bee possible reason
For this to bee happening

First changed oil (10/40 though I need a heavier oil) and added oil treatment a few weeks ago because of a loud tapping or ticking noise. Car still had noise but did quiet down. Now car has a very loud knocking noise at idling and acceleration. Almost sounds like something is hitting against something

Static comes through speakers with radio off