Close

Chevrolet Impala Questions

Get answers to questions about your Chevrolet Impala at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
1,684
questions

when riving over 60mph the car loses power and will not take gas. I stop, turn car off for 5-10 minutes and it starts up and does better. Is this under warranty and how do I fix it?

Now that its warmed up, I don't hear the noise?

thanks,

jk

i dont have the owners manual

Haven't seen antifreeze on the ground. Windshield doesn't have a film on it inside. It just smells sweet.

back up lights not working already chckd fuses and relays and bulbs lights do come on with security system what do I do to fix them and where is back up light switch?

the lights do go on with security system

i got a code p0304 witch is miss fire from the spark plugs i just replaced all plugs and cords and it is still there what should i look for to know why the plug is not firing properly

Had to have windshield repaired when rock hit it. Now leaks 3 years later when it rains.It rains on passenger side when sitting on a hill.

if i get my hand in the door is there a switch to make the latch pop open to open the door and remove the panel to fix the problem??

it does not have the 4 screws in compartment

what would I need to do this?

Everything else is working fine.

I have to spray WD-40 in the slot to correct a problem. What is the cost for fixing this particular problem.

this just started this week as the weather changed.

I replaced the door acurator due to the clicking when heater is turned on. Now it smells like burnt rubber (or something burning) through the vents.

when I turn the steering wheel all the way to the left i hear a rubbing or grind noise at a very low speed

There is a knocking sound coming from the area behind the glove compartment when the motor is shut off.
We were told it probably was a gear.

When I shut the car off a loud clicking noise begins located up by the passengers dashboard area. The noise continues for about a minute then stops. So far it does'nt seem to be affecting the performance of the car.HELP PLEASE!!!!

evrytime i run over a significant pot hole the car goes off and i have to put it on neutral to start it back on,i thought it was my ignition module connector that was loose as it was a little loose the screw that holds the wiring harness in place.i tighten it but still i got the same problem when i go over pot holes.stupid car gos off.please i would appreciate if anybody knows this problem and knows the fix.cuz this car does that to me on the highway too and thats dangerous.i dont want somebody to rear end my car and possibly get kill or injured in an accident.thanks.

what does chevy recommend

engine starts and runs but security light stays on

changed the pump, checked the jets just cant get enough pressure. No hoses are leaking

The car died driving down the road. Went back later and it started and ran fine. The next day didn't start. The battery was weak so replace that. checked the charging and that is ok. Put fuel pressure gauge on. Has 53 psi with key on. The car started 2 different times after checking pressure. Now it dosen't start at all just cranks. Any idea's?

my engine overheated once and then the second time i was on an interstate and the engine died to were i had to pull over. i dont have much money and want to know it this can be fixed

Recently I let my vehicle sit for atleast two months after replacing BCM. So I finally replace my transmission filter but now I hear a tapping sound coming from the engine. I have replaced spark plugs and change the oil using synthetic oil also. Now temperature stays at normal level. When I put the vehicle into reverse it tends to jerk. Once I put the vehicle into drive it begins to drive but acts as if its missing until I get into higher speed and runs fine until I slow down. Also I my check engine light flashes on and off.

i have understood that by putting in an aftermarket stereo without the module sometimes the comp. starts to act funny could that be my problem? that happened to me when i put different size tiers on my car when i took it in all they did was reset the comp.

what is happening to the car?

My driver's side temperature control is kicking out cold air and my passenger's side is kicking out hot air no matter how I adjust the temperature. I don't know if there is a fuse that is blown or if I need to replace something else...?

The car has a column shifter. I have replaced the brake switch,
the shifter, the interlock switch, shifter cable and etc. Shifter works fine if cable is not attached to transmission. I can shift transmission with a wrench, but hook the two together and shifter and transmission will not shift out of park. Please help.

JUMP START DRIVE HOME-AROUND TOWN GOOD ONCE AGAIN DEALER CKS SAYS BATTERY, NO SHORT, NO SLOW DRAIN ALL GOOD CAN'T FIND PROBLEM. CKS EVERYTHING-HAPPENED AGAIN FOLLOWING WEEK DROVE 50 MILES 40 MINUTES LATER DEAD BATTERY- AAA JUMP START- SEENS IF I DRIVE 1 OT EVEN 2 HOURS STRIGHT AND STOP BATTERY IS DEAD ANY SUSJESTION ON WHAT MIGHT BE CAUSING THIS- THANKS