Close

Audi 90 Quattro Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
One day while driving the car my climate control display was dimming out and finally went blank. It now has no function and the only way to get anything to work is if I unplug the far left plug from the back of the unit. This will kick the blower fan on, but nothing else. I've checked all fuses and they're fine. Wondering if you guys can help before I take it to a shop. Thanks
94 audi quattro 90 - cranks but no spark
ACID leaked from outlet spouts of battery onto the hose which overtime ate away the hose // Also Brake and ABS lite sensor come on and beep>
5 years ago the odometer on my 1990 Audi "90 Quattro 20v" suddenly stopped working when the car had only 49K miles. (Yes, only 49K miles, and I'm the car's original owner.) Anchorage's only Audi dealership said the odometer could not be repaired or replaced on that model. The speedometer works fine (like the rest of the car). Any advice/info on whether my "vintage" car's could be repaired or replaced?
i need the torque wrench settings for the oil pan bolts
I was driving my car down the road and it just quit and it won't start back up. The fuel pump turns on. checked the spark plugs and their's no spark. I've tried replacing the ignition spark module and that didn't work either. I just don't know what else to check. The parts are so expensive for this car and just wondering if anyone has any ideas.
engine died while running. it will still crank but there is no fuel getting to spark. it is still pumping fuel but not getting any or enough through.
I have a 1988 audi 90 quattro and I'm not sure of the location of the crank sensor. I think it is mounted on the tranny where it mounts up to the engine. The problem is that there are two sensors located there, one is a little bit higher up to the left. Wondering if it is the speed sensor? Anyway I'm not sure how to install the crank sensor. Any help would be greatly appreciated.
Car runs. Parking and brake lights OK. Radio plays.
All else electrically dead...headlights, turn signals, horn, window controls...
Which is the rely for the power windows?
i bought the car it has 226,876 miles and the car runs very good. but the heater does not blow very warm air. and while sittin still the temp hand will raise and the heat gets better. but as soon as you go down the road the heat go back to cold basicly. i have checked the oil and the coolant there is no aparent mixture of either. but there is no loss of either. i thought that maybe the thermostst has been removed but i havent checked. what could be my problem
as i said i changed the oil and filter . ran car for about 20 miles parked it light did not come on the whole time. Then noticed oil leak at oil pressure switch for the light was leaking pretty good. So I want down to autozone put the one they gave me in now light and buzzer go off again above 2000 rpms. Oil pressure at normal temp is 2.5 bar and goes up with rpm. Maybe wrong switch? The one I took out is original equipment. says 1.6-2.0 bar on it. Maybe something in oil screen at oil pick up? I don't know because I have good oil pressure.

Thank You
Matt 95 Audi Quattro 90
what bar number do i need or does it make difference? got good oil pressure according to gauge. i have both light and gauge. maybe pinched wire? Dont think it is oil pump? dont know not mechanic
i changed oil to correct grade and KnN filter drove around and lights and dinging did not go off. When I got home noticed oil under car good size to. Found oil sending switch leaking so I replaced it with one i got from auto zone. Now light goes off and dinging again. do you need correct bar number for switch? I don't know what bar the one I got at autozone is? The one that came out says 1.6-2.0 bar. Still have good oil pressure. Only comes on above 2000 rpms. thank you
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.