Close

Acura TL Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
951
questions
Leaking oil and was told it was the gasket. What does this chore run money wise to do yourself or in a shop
I have a 98 Acura TL 3.2 l I have changed the VSS sensor that didn't work change the VSS power steering adapter that the VSS mounts to that didn't work I have changed the cluster 3 times that didn't work the plug is getting power is getting ground just don't know what's going on I have checked all the fuses and relays
I can't open the back door!
The VSA light and a triangle with a exclamation symbol illuminates when I start my car. The car won't run right, until I turn the car off and restart it. Leaving the check engine light on. It also cuts off during down-shifting. Also, running the a/c for long periods of time, makes it run bad. Which also, makes the car cut off while driving. What could be causing these problems?
Started downing about 5 months ago about once week, last two weeks, it shuts down every time I drive it. Check engine light does not come on.
Nothing more to add.
When the hood is lifted, it must be held open.
So do hazard lights and blower fan
for about 20-30 min then u can take it out of park n the switch un lock, what my baby problem this happen when ever I drive my car n put it in park after abt 20-30 min it ok.
2002 acura tl 3.2
Just died while driving down road. No electrical power. Replaced battery and generator as told. Drove one day. It did same thing.
Car just died. Put in new Altinater and Battery. Died again after one day. While driving. No electrical Power.
It only does it when first crank up what's the problem just had catalytic converters change
Threw out the day it starts regular but in the mourning I turn key, everything comes on but it will take a second to start.
until i accelerated to 90 mph passing a car. she started missing a little during the acceleration and got worse during deceleration. it continued for the remainder of my trip home. after about 15 minutes i went outside to start her and she is missing all the time now and the check engine light is now flashing on and off. they had to replace a coil for one of the spark plugs that broke when they tried removing it. for the service they replaced the timing belt, pulley, water pump, checked the valves for adjustment (no adjustment needed), serpentine belt, spark plugs and one (1) coil that was broken. Any advice or diagnosis?? i sure don't want to damage her trying to get it back to the mechanic?? Thank you!!!!
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.