Close
QUESTIONS

RepairPal is your advocate for car care advice and guidance

Q: no dash lights, flat line guages. on 2005 Ford Five Hundred

Edit
first thing the wrench light went on with the airbag light. Then the guages flat lined and I couldn't tell how fast I wa going, no gas guage, etc. The lights, radio other electronics work.The guages would shake like a surge and then go back up. This has been going on for three weeks. Now I have no guages working, reverse lights stay on and cant get my car started! Replaced the battery in the theft lock on my key ring, but no help. has 77,000 miles and was running fine until this happened. Now i have nothing working. Single mom---can anyone help?
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
I am thinking that you have a voltage or amperage power problem from your vehicle's charging system. Specifically - have your alternator performance checked at an appropriate qualified shop by a good tech.

An alternator with poor output or a bad diode internally can cause all kinds of erratic behavior with your electrical components.

Click this link for a shop directory near you! https://repairpal.com/ford-repair-in-flint-michigan

Good luck!
Common problem with these instrument clusters. We repair these and many other instrument clusters at a very reasonable price. Visit http://www.mrwhizard.com for more information.
Didn't find what you were looking for?