Close
Car Questions
RepairPal is your advocate for car care advice and guidance

My car is missfiring and backfiring

(1990 Cadillac Seville)
in Bluefield, WV on January 18, 2014
I have a 1990 cadillac seville. It has been missfiring on me and it backfires and looses power sometimes. The service engine light comes on and goes off. I changed the distributor cap rotor button and plugs and it still does it. I turn the car off and start it again and it runs better. The other day it backfired and was losing power i cut it off and started it again and it backfired real loud and it blew my muffler apart at the seams. I changed the muffler and its still missfires and the light still comes on and goes off. When i barely hit the gas and go under 40 is when its missing and jerking when i step on the gas and it opens up it doesnt jerk. Does anyone know what it could be
Displaying 2 answers & 5 comments
Popular Answer
on January 18, 2014
Go to youtube and watch the video on 'how to get obd 1 gm codes' and get your computer codes so you can post them here for more info. Plug wires in good shape? Does it have an air pump/smog pump on the engine? And...how many miles are on it?
on January 18, 2014
Thanks for the response i will check that out. I havent changed the wires but when i put my hand on top of the distributor cap one of the wires shocked me and i can hear the rotor button make a clicking noise as it spins i wasnt sure if that would cause all of the problems it has 160000 miles on it so i guess i can expect to have problems. I looked online and there was a recall on that model for the egr solenoid/valve failure if that would have anything to do with it im not sure. But thanks for the advice.
on January 18, 2014
That clicking noise is IGNITION FIRE! Been there, done that and got the t-shirt!! Replace the plug wires and keep them in the correct order! In fact make SURE the firing order is correct after new wires are installed! Does it have the smog pump??? Forget about the egr for now.
on January 19, 2014
Yes it does have the air pump on it
on January 19, 2014
Two things; IF the air pump is still running, being used, remove that belt!!! Then replace the plug wires! LET ME KNOW HOW IT RUNS THEN.
on January 19, 2014
Catalytic converter is clogged, vacuum leak or O2 sensor is bad and sending the wrong signal.
on January 19, 2014
You think so? Muffler blew off!
Get a repair estimate
RepairPal estimates are guaranteed at over 2,000 quality certified locations nationwide.
Or interested in getting a repair? Find a Shop
Didn't find what you were looking for?