Close

2001 Mitsubishi Eclipse Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
I can not get in 3rd at all. 4-5 free wheel. manual trans. 1-2 ok reverse ok so far...
This happens with no rhyme or reason.And when it does crank the car runs great???
windows work but my remote for the doors don't . we removed the starter and had auto zone checked it nothing wrong with it.we can pop the clutch and runs fine.?????? can any one help me please ?
to do with me not being able to go into 1st or 2nd gear (manual transmission)
I would like to know about reporting a potential insurance fraud issue, coupled with employment underpayment. I am dealing with a mechanic who receives estimates from the insurance company for a repair. The estimate quotes a particular number of hours and new parts. The mechanic then directs his employees to complete the job in fewer hours, with used parts. Mechanic then bills the insurance company for the original estimate (with extra hours and new parts that were never used). He is defrauding the insurance company and short selling his employees. Who can I report this to? Better Business Bureau? Bureau of Automotive Repair?
I'm a retired mech,mostly motorcycle,but ten years gen. automotive.I bought a 2001 eclipse a year ago,186k then 198k now.2.4 stick.It had a slight rattle I at first suspected to be a shroud or exhaust component. Since then,the noise has increased.Its not an engine noise,it only happens when moving ,and louder when coasting downhill in gear.Once out of second it goes away.I put the car on blocks,and ran it.It was quiet until I put it under load with the brakes.I could feel the rattle through the clutch fork,as well as the trans housing.It occurred with either wheel stopped.I'm thinking throwout bearing or clutch pak. please advise...thanks,mike...
Freeze frame data:
Fuel system 1 : open loop - drive
" " 2 : " " "

Calculated load: 40.7%

Engine coolant temp: -40.7F

STFT Bank 1 : 0.0%
LTFT Bank 1 : -0.7%

STFT Bank 2 : 0.0%
LTFT Bank 2 : -0.7%

Emgine RPM : 562 RPM

Vehicle speed : 0 mph
coil also gets hot ans burns oiut.I canged plugs ,coils,woores,coolant sens,cam sens,crnkshft sensor,fault sensor ,iac,tps ansd relays and also gets power please HELP
Ok here's my problem. I let my car sit for a few weeks. Started it and went to a gas station and filled up. Went to work without any issues. When I went on my lunch break my car stalled about a mile down the road. Ran scanner and I was throwing a code for bad egr valve. Replaced egr still got the code and won't start. Replaced egr solenoid and the code was gone. Car still working through start. Ran scanner again and got a code stating the iac idle was low. My car will start if you are giving it gas. The fuel pump is running. If you hold gas at normal idle and let it warm up it will stay running at 400 rpm. And it will throw light white smoke from time to time that doesn't smell like coolant. Any help is welcome. Thanks!
We just bought a 2001 Spyder Eclipse. We do not know when or if the timing belts has ever been replaced. How can we check its condition. What is the ballpark figure if it needs replacing? Thanks!
Looking to buy one, but the heat in it is bad, and I need to know how much it would be to fix ir
car would not come out of first gear stuck turned motor off only then could i run thew all gears and car was fine. same proublum 2 days later locked in first turned motor off was fine.difficult to shift threw gears next day car was perfect no hard shifting no lock up .seems to be intermitent replaced slave cyl and bleed no change no leaks pedal feels great and linkage feels good dam it happened again locked in first turn motor off and its good to go seems to be electrial are there any solonoides or relays that could cause this.
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.