Close

1999 Mercury Mystique Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
I am trying to replace my drivers side lower control arm hut cannot access the bolt because the transmission/engine is in the way. I looked at the front motor mount and the nut is oddly shaped. I would like to know what special tool I need; a way to get the motor mount off; or if there's another way to remove my lower control arm!?
Tried priming. Fuelpump is working. Car is turning over but won't start
water pump,heater core, thermostat,radiator cap,and flushed the system. dont know why it wont hold pressure, and it does not use any fluid.
the ignition now that its been replaced the only thing it will do is all the lights on dash will work I just wont start....
Cable or wires from battery to alternator
Hi all,
We own a 1999 Mercury Mystique, 2.5L V6, 24 Valve DOHC.

Recently the car broke down and we're working through fixing some issues it's having, and we'd appreciate some advice on something we found. While looking at the intake manifold, we noticed raw, liquid fuel poor out of a tube on the driver side, closer to the firewall (top right of picture below), and similarly in some vacuum tubes.

A potentially related symptom we found is while replacing the exhaust O2 sensor, there was what we would call an excessive/heavy amount of carbon build up on the sensor.

Manifold: http://bldouglas.com/etc/car/1.jpg
Vacuum lines: http://bldouglas.com/etc/car/2.jpg

We have a home OBDII reader, and the car currently has these codes:
P0155 - O2 Sensor Heater Circuit
P0156 - O2 Sensor Circuit
P0401 - Exhaust Gas Recirculation Flow Insufficient Detected
P1520
P0171 - System Too Lean
P0302 - Cylinder 2 Misfire Detected
P0301 - Cylinder 1 Misfire Detected
P0161 - O2 Sensor Heater Circuit
P0174 - System Too Lean
P0303 - Cylinder 3 Misfire Detected

Any and all advice on what may be causing this or other issues and a starting place would be much appreciated! Thanks in advance!
Every time I drive off or go over 40 and have the ac on the car will pull back or slip does any body know why I have a mercury mystique 1999
was under the hood checking to see where a squeaking noise was coming from when the car stop starting !I kept trying to start it and then one of the ground cables started to smoke,I figured it was the starter I let it cool down and tried it again and it turned over slow but it did start, I then drove back to Dallas (300 miles)and it did not start again. I installed a new starter and it turned over good the first time and then started dragging and the ground started smoking again. I installed another starter and also a new ground and it did the same thing, It turned over good one time and then started dragging again and has not started, I can hear the fuel pump and it do seem to be getting gas and I don't know what else to try, can you PLEASE help me ?
do i have to pull trans
Are there anymore salvage yards. Other than Redwine.
It has also started to flash on and off while pressing down on the gas pedal. This is with the brake handle down or off. It flashes on and off.
I REPLACED THE INPUT SPEED SENSOR AND THE TRANSMISSION STILL JUMPS BACK AND FORTH IN GEARS.yOU WILL BE DRIVING ALONG AND THE TRANSMISSION WILL JUMP DOWN TO A LOWER GEAR AND THEN JUMP BACK UP TO THE HIGHER GEAR. IT FEELS IKE THE TRANSMISSION IS GOING TO FALL OUT. THE CODE READ THAT IT WAS THE AUTOMATIC SPEED SENSOR. BUT SOMEONE SAID SOMETHING ABOUT A TURBINE SENSOR. NOT SURE IF THEY ARE THE SAME.
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.