Close

1998 Mazda Protege Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
light bulbs good
Runs good check engine light still on
No pwer to fuel pump. Relays seem to check out. Have spark. fuel pump not kicking on when go t sat art car resulting in a crank no start problem. All of this after I hit a bump in road and car died
The air conditioner doesn't work due to an electrical problem. The compressor and relay work fine.
Could someone give a straight answer on the question, I already know the fan does not work, I just need to know the costs parts, labor, taxes and time involved in doing this repair.
my O/d light turns on it blinks and the check engine light stay solid yellowand ask if I'm going 35 40 miles per hour I like goes into neutral or shifts down and when I park and leave it in park sounds like the engine is celebrated
can buy online a radiator for around $100,and give to you to be fix just to save cost. Thanks Michael (Aus)
after car sits for a few hours it takes a long time to start,i smell fuel,and it sounds like it wants to start, but wont,only after 15minutes or so of cranking the car finaly starts, after that it starts fine evrytime...as long as it dont sit for 2 hours..please help, any info, or suggestions are more than appreciated
Turned car over but would not start, rolled down hill and popped clutch no start. Replaced: Plugs, Wires, Cap, Rotor, Fuel filter, Air filter, checked oil (good), battery is charged and takes and passed load test, Spark at all 4 plugs, fuel on plugs. No codes. Removed air hose to manifold and tried starting fluid, still no start. All viewable fuses are good including main 100amp fuse.
My car sat for 2 weeks at the mechanic to have the serpentine belt replaced (in well below zero temps the entire time). I get it back, turns over, runs hard for a few blocks as fluids get moving again. Got it home and there was no engine coolant in the reserve. I'm noticing that my thermostat is not moving past Cold anymore. Put in new coolant, level has stayed for 3 days. I run an average 10 miles one direction. Still blows somewhat warm air with heat on. Sorry, no codes. Thoughts?
cranks but no spark,and fuel pump wont kick on.ive replaced the distributor,with another used on(car was running)....the crank positioning sensor reads .557ohms what could be the problem?
I'm going to change te tires because they are worn out.
i have a 1998 mazda protege i seem the check engine light come on a few weeks ago i saw it needed power steering fluid i put some in and it went off. it just came back on the other day and i have checked all of my fluids and there good. i know my main transmission seal is leaking. what could be the problem'
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.