Close

2003 Mazda Mazda6 Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
and the codes po340 and po128 keep returning. the engine surges a little and at hwy miles mph 65 to 70 the rpms go crazy but nothing major drivibility wise. can someone please help???
While driving the it felt like it wasnt getting any gas and would shake and felt boggled down till I hit second gear. Had engine light code read and said it was spark plugs. Replaced them and engine light went off. Later driving it came back on an car was doing the same thing again. Had engine codes read again and they code couldnt pin point the problem. Read on other sites possible coil pack, fuel injector, etc. Does anyone have any clue as to what the problem is? Also it has 155k miles. Ive replaced the battery 4 times, altinator 4 times, pcv valve, and intake manifold all within the last 2 years. Please HELP!
No code is showing up.I changed mass air sensor.It will idle but when you put in drive it starts missing and it will go about 10mph and when you try to give it gas it just misses and sputters.
the pulsation occurs when applying brakes to stop and the check engine light is on or it blinks on and off.
AND flywheel def. has some teeth missing. Would that be the main cause of problem or could it be the problem is with bendix and once that is replaced it will still run with the missing teeth on flywheel?
My car started making a grinding noise sometimes when I tried to crank it, and would take several times to crank. It became worse and worse until it just wouldn't crank at all one day.A man at the gas station heard it once and said I needed a bendix. Is it too late now? Or will that fix problem? AND how hard is it to fix, and do I need special tools? Sorry I sound like an idiot, I know I should of done something sooner, money too tight, now I'm hoping it will be a quick fix!
have to warm car up for 20 mins before it kicks in drive beside that the car runs like a race car
it does that every morning, was told its the engine seat, just changed it but still te same.
it happens on new O rings old O rings even when i lube it up good it fails. i just had the motor replaced so i dont want to do that again. what can i do.
Immediately took it to Mazda dealer. Was told it was weather damaged and had stretched and broke one sensor.
Almost 5 yrs. ago I had timing belt replaced by another repair place due to an accident at 40-45000 miles. Now my car has only 76000 miles on it and it needs to be replaced due to weather damage? Is this correct? Could
weather stretch it out causing it to damage a sensor?
it happens everytime i turn on my AC for a prolonged amount of time it begins to jump and my speed then decelerate and i have to pull over cut the car off then crank it back up then drive again without the AC on it only does this when the AC is on not with the heat
Can't figure out how to get the plastic cover off and then how to get to the bulb
At cruising speed of about 60MPH, when I suddenly accelerate (punch it, to down shift the auto-trans) the engine will suddenly turn off and all my instrument panel indicators would light up like a Christmas tree. When this happens I shift to neutral, turn off the ignition and restart the engine and it all starts working properly again. I wonder if I have some kind of electrical problem where the sudden jolt of the engine is knocking something loose.
parked the car one night went out the next morning would not start
I hear a squeaking noise when my front wheels move while parking.
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.