Close
QUESTIONS

RepairPal is your advocate for car care advice and guidance

Q: mass air flow sensor on 2000 Buick LeSabre

Rookie cbe0621eac06868b3efe0d8d1d3611e23c60d3114864ea2ec19a68cfbd3eebab
i have a 2000 lesabre ive replaced the maf sensor twice but i still have the same code it but when i start car it turns off but it runs once fuel pump comes on
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
You have to make sure there are no vacuum leaks in the intake system, make sure the connector terminals are clean and tight and the wiring needs to be in good condition. This mean you may need to check the wiring with a volt/ohm meter between the MAF and the ECM. Check the ground wires very closely as well.

You may have another issue as well, check the fuel pressure and make sure the pump is working normally.
po102 mass air flow sensor or vaf low input but once the fuel pumb makes noise in back of car the car leavels off
Just an FYI for those still reading this post. The noise that appears to be coming from the fuel pump in the back is not the fuel pump, but a leveling motor to the suspension system. When the car is started, a sensor in the rear tells the motor if the suspension needs to be raised, which will occur more frequently with shocks that have not been replaced in a while.
Didn't find what you were looking for?