It will start but will not idle or run on 1990 Ford Aerostar

Ok here what I have done so far. I have changed the fuel pump and fuel filter. Changed plug and wires. Fuel pressure regulator has also been changed. The only way I can get it actually run is spraying carb spray into the intake. I have checked for vacuum leaks but not that would keep it from running.

by in Quinlan, TX on March 09, 2011
1 answer 1 comment
ANSWER by on March 09, 2011
You need to check the fuel injectors for power and ground control signal, the injectors should be hot when the EFC relay is energized (when the ignition is on), and the ground is controlled by the computer. Look for connector problems between the injectors and the computer. Make sure you have fuel pressure when the engine is cranking. If you want to find a specialist, here's a directory link for you:
COMMENT by on March 13, 2011
I figure it was a bad relay however changed them and nothing changed. I am pretty much going to have to change out the computer brain. I just refuse to believe that all 6 of the injectors are stopped up or not workin
Related Items:
I've run the devil out of my Aerostars over the years -- and I now still have my third one a 91 with a 3.0 which I have used as a commercial vehicle in the past with good success (including the cla...
my van starts fine, but when I put it in drive and excellerate, it dies. It takes several times before it starts and I have to let it run for a while before it will go. It also has a light miss at...

Related Content