Close

2003 Hyundai Tiburon Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
It happens at the mid to higher rpms in every gear 1-6. When I am driving down the road and shift gears the car accelerates fine at the lower rpms but when the car hits about half the gears range it starts to run higher rpms but goes no fast
2003 Hyundai tiburon v6 gt it runs fine until it hits 200 degrees and then back fires and spits and spudders
any body nows why?
My husband said the cylinders are messed up and would be easier to replace the motor.
The car cranks but wont start without a jump start and turns off after a gasping air sound and 1 min being on.
i have a promblem with it starting i put my foot all the way down on the clutch and it starts loosing compression hat can it be
driving over even the smallest potholes, its making a loud thump noise, what should i be looking for, going out to try figure whats wrong, thanks
2003 GT V6 Automatic. Idles well in park, but when I am at a stop sign or stop light, it seems to "surge" and wants to go forward. I don't know if it is an engine surge thing, or a transmission thing. I don't notice any other problems with the engine, or with the transmission. Just this weird surging feeling when fully stopped. I've even checked to make sure the engine mounts seem tight, just to be sure it wasn't some type of "slipping" because of that. No codes are being thrown. I currently just put the car in Neutral and wait for the light to change. No "surging" in Neutral, either. Any thoughts or suggestions?
Car was running fine a month ago. Installed a new air intake filter, yesterday. Cleaned car, including spraying some water under the hood, which may have affected something. Started car, idled very well, put in gear, applied gas, released clutch...car coughs and sputters, then dies. Multiple attempts, no go.
At first the engine would rev high so I would shut it off and restart then would put in reverse and it wouldn't move or engage until giving it gas. Can you tell me what the problem is? Not sure if it needs a new tranny or if its and idle sensor. Mechanic said it doesn't have a vacuum leak. The problem seems to happen after I've driven it for awhile
in cold weather it seems to werk fine i went to idahoe and salt lake this last winter and it ran fine i could shut it off restart drive slow fast no problems over 2000 miles and about a week when i got back down to arizona it started acting up again. it had this problem b 4 i went but new about the cold weather thing so i thought i try it its been sitting ever since its no fun to drive when it wont rev past 3000 thanks kidad
When I try to leave in first it grinds and hops out but not in anyother gear
cud it be bcm?
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.