Close

1993 Honda Accord Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
155
questions
My car started slowing down and shutting off, more like it was not circulating gas or oil. I knew my oil was low, but all other fluids are full and has about 4 or 5 gallons of gas still in tank. i have replenished the oil needed for car to run, but won't start.I have tried so much to start it that the battery has begun dying.
All lights in the dash board light up indicating doors/trunk open when they are not. These lights dim on and off sometimes or turn off compeltely like normal. The SRS light stays on all the time. The Honda dealer said they never seen anything like it. 90$ and hour till fixed.. hum sounds like a big bill to me. The car only has 100k miles on it and in really good condition.
I have changed my fuel pump and ignition coil. Took off the distributor cap and something was loose on inside cliped it back in didnt start right off but then ran great for a lil while then shut off again.
cost for repair
the engine virbate yu can feel it and the whole front end shake,
It's the wish bone style. The bearings come out with the rotors.
The faster I'm traveling and I apply the brakes the more it shakes.
my 1993 honda the engine tempture rises only one fan come should both fan come on
4 cyl, 2.2
helppp please
Smell is most proiminent when A/C is on. Usually strongest after vehicle has been driven about 30 minutes
Shop already replaced Return and High-Pressure Hoses and the Pump itself....what else could it be?

There is no knocking or thud sound when I turn, so I don't think it is the Rack-n-Pinion, or could it be?
new distributor,new coolant sensor,new oxygen sensor,new plug wires,new spark plugs.Map sensor checks good with volt ohm meter,also the throttle sensor checks good.no cel codes.
there is spark to the spark plugs.has good fuel pressure.the injectors are receiving voltage[checked with noid light] the main relay clicks twice. I got it started once and checked the timing and it was ok.It sputters on first attempt but not on any other attempts. Note the time it started it ran fine.
Should I repair only the boot or replace the whole rack?
Steering is good and fluid level is fine.
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.