Close

2011 Ford Expedition Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
will knock for a short time after starting the car - doesn't do it every time, just occasionally
What seems to make the problem better or worse? longer car runs
How long have you had this problem? 16 months

What seems to make the problem better or worse? nothing
How long have you had this problem? 10 days
need to know how long it would take to replace the engine
Last summer my truck had numerous moments when it all of a sudden wouldn't start. Sometimes it would go weeks without doing it, and then all of a sudden would do it a few times in a week. It would always turn over, just never start. Usually it would take 15-30 minutes of waiting and then it would turn over no problem. I had the fuel pump replaced before winter and went 9 months with only one incident, in which it started a few seconds later.
Unfortunately it happened yet again the other day and would not start for like 40 minutes. Is there something temperature related that could be helping cause this issue? Any ideas on things to check?? Unfortunately it never happens at the shop so it can not be tested and there are no diagnostic codes.
We have had the vehicle into the mechanic several times. They have walked through the vehicle wire by wire and reset the computer but it continues. When everything is reset the vehicle usually runs a day or two with no problems, then the issues re-occur.
The sound lasts for about 10 seconds and goes away. Occasionally it will happen when driving, but always when it is started.
The paint is starting bubble up as if rust is coming thru from underneath the paint. It is on the front of the hood and various areas on the back tailgate.
When I turn my ignition to the on position it sounds like someone knocking on a door. The sound appears to come from behind the navigation. It stops after the car is running in a few seconds.
It stop working instantly. It happened as I was leaving from getting my tire fixed. Could that have something to do with it not working? My car has 40,000 miles on it and is in great shape.
The dealer said that I needed to replace the evaporator vent solenoid. I did that and the light stayed off for approximately a week but now is back on. What could be the problem. I don't remember the code but was told it had to do with emissions.
i BOUGHT A USED 2011 FORD EXPEDITION WITH 2,000 MILES FROM AN OUT OF TOWN DEALERSHIP. I RECENTLY EXPERIENCED ENGINE STEAMING WITH BURNING SMELL AND THEN EVENTUALLY MAJOR EXHAUST SMOKE. FOUND OUT FORM DEALERSHIP IT HAS A FRONT PUMP SEAL MISSING (AND LEAK) AND AN EXPECTION COVER MISSING. THE SERICE CENTER IS PULLING APART THE ENTIRE ENGINE TO MAKE SURE NOTHING HAS BEEN EFFECTED. SHOULD I BE OVERLY CONCERNED? WILL THIS MOST LIKELY LEAD TO FUTURE PROBLEMS. I AM AFRAID I BOUGHT A "LEMON"
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.