Close

2003 Ford Expedition Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
148
questions
It will crank and then shut off when you try to put it in gear.. Then when we try to crank it again it's giving a clicking sound
On my 2003 ford expedition my pcm power relay fuse gets hot and blows the fuse and won't start makes a buzzing noise but when I change it it starts right up no problem sometimes a 2,3 weeks sometimes the next day.
Never had light on before states service engine soon
What seems to make the problem better or worse? Engine warm
How long have you had this problem? Just started
Question just started 03 Expedition will get lights to flash on dash 4x4 But switch in 2 wheel drive location
what causes this and what is required to resolve issue
What seems to make the problem better or worse? Nothing
How long have you had this problem? just started
Looking to do myself
Can this be done without removing door lock
Have new cable
What seems to make the problem better or worse? Never done before
How long have you had this problem? 3 months
My turn signals went out on my 2003 Ford Expedition Eddie Bauer. I replaced module under the driver’s side dash. Now it cranks but won’t start. Could I have accidentally hit something, disconnected or broke something under there that would cause this? It was running great prior to this. About 240,000 miles. Any help would be fantastic. Thank you
What seems to make the problem better or worse? It just cranks
How long have you had this problem? hasn't started in two days
Doesn't shift into overdrive. Must drive with the overdrive turned off. Otherwise transmission works fine.
When starting to move I can feel a grinding seems to be coming from the left front wheel. Its very noticeable when turning left. After a few moments as I pick up speed it vanishes. Had a mechanic look at it and he said everything looks ok. He's baffled. Suggested I contact Ford to see if their have been other similar complaints and a resolution. This has been going on for awhile. ( I'm retired so I don't drive everyday, Maybe two days a week to the store and back most of the time. But it is becoming more noticeable) Any ideas??
My expedition is not turning on or makes no crank my lights turn on but not my sterio I change the baterry to a new one it wasn't the problem I took the starter off to get tested and it wasn't the problem either is something electrical so what can it be?
Not long ago I drove to town without any trouble or incidents. I came home,
parked my vehicle. Not a single problem or noise. I have not attempted to
even start it in maybe 3 weeks. So I decide to drive it to town. The battery
was down. So I jumped it off. But this time, it would crank. But would not
start. First time it has ever not started. 75 degrees out. The only indicator is
the "oil pressure low" came on. Still will not start, but cranks just as it always
has. The oil level was good. I have tried starting it a few times, and it cranks,
but will not fire. I noticed while it was cranking, the oil pressure does not
change while cranking. It remains at 'no pressure', which is odd, because it
has always had good pressure. Will "low oil pressure" indicator cause it not
to fire? Does the pressure register while cranking? Any ideas?
Car was running fine , parked it ,later went to start and engine turns over but won't crank. Found another troubleshooting site suggesting fuel relay in fuse panel that iscsoldered in so I replaced the whole fuse panel with new one. Still won't crank up. Located the restart button on fuel shut-off in rear and tried that. Doesn't seem to be that either. What to check next?
I started driving one day I noticed my O/D light was blinking on my Dash I recently changed the fluid on my transmission and my transmission is Shifting great I don't know why it started blinking does anybody know why this is happening?
No power on acceleration and would die in reverse.
I see everyone having the same problems I had with my 2003 Expd. Stalling, then cranking but not turning over. I changed my fuel pump, my battery, my fuel filter, and then I got some good info. The relay Fuse board in the Expeditions are somehow getting damp. The fuses when damp will burn up. I found a relay board and ordered a new fuel relay fuse. Luckily I knew a fellow who saudered my new fuse on and my truck started! I dont know how Ford is getting away with no recalling this fuse moisture issue. Good luck all. I hope I didn't confuse the hell out of Everyone.
We replaced all those parts and still no start I am getting a buzzing noise from the fuse box any suggestions on what the problem could be please help
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.