Close

1999 Ford Expedition Questions

Get answers to questions about your 1999 Ford Expedition at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
204
questions

1999 ford expedition Eddie Bauer 5.4 all wheel drive under load front end clicking, and in 4x4 clicks loud when turning right or left, i have changed the universal joints on front drive shift, each side wheel bearing assembly and both axles and still clicking need help

Check your fuses. I drove without heat for 4 years in the front. Went to replace the blend door actuator and the old one worked after we tore apart the dash. I had a blown fuse. Go through your owners manual because there are several fuses that tie into the heating system. I had already had the radiator replaced, the heater core flushed and had several certified mechanics look at it. Hope this helps someone

Throws a cam sensor code po340. Replaced it didn't fix the problem. Took it to ford they said the wiring checked out fine. They called and its now running fine they did not fix anything. Pickec it up got half way home and it is now doing it again.

When I plug my scanner in I don't get any power, is there a fuse

Reverse works but forward does not

Seems like a universal joint or a bearing in the rear wheel vibrates when starting out mostly when Turing. I know AWD are a little funny but this seems like a little much. Thanks Dave