Close

1991 Chevrolet S10 Questions

Get answers to questions about your 1991 Chevrolet S10 at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
84
questions

the lap belt no longer retracts and locks

2 wheel drive, I have rivets on left side cut off with floor jack under control arm. nut on upper ball joint is loose, need to make sure if brake caliper and rotor need to be removed.

I replaced the coil. it stars unmounted but not mounted to. The block

I keep adding fluid, and keep losing clutch.

checked fuel pump, fues, and relay.

thermostat has been changed,hoses are all hot to touch,hoses out of heater core are both hot,cable style control inside of dash seems to be working( i hear flaps moving around)..what could it still be? its not like a dead winter cold that blows out of it, just feels like it has a tinge of warmth to it..just not a lot or enough to do anything really..

Heater coil has been replaced as well as heater hoses and radiator fan runs but blows cold air

not sure if the above is the solution. My check gauges light comes out at low idling and oil pressure stays in red zone but goes up at i accelarate. oil level is normal.

it has been doing it more often it idles really rough step on gas a little then it will idele better runs really good just does it after it sits awhile or over night

I was told by a friend that this requires dropping the entire steering column.

I would like to check it myself at home with out taking it to shop.

173,000 miles on it, fuel filter an tuned up at 140,000, stumbles bad when u try to accelerate, no gas smell, just started all of a sudden, put regane fuel system cleaner in it an didnt help, feels like its in fuel system not electronics, feels like its starving for gas, please help.

I have released the screws, but cannot get the switch to come out. I think I need to replace the vacuum hose(s) attached to the back. Where can I get those hoses?

Have a '91 4.3 L that backfires after it is started, have installed new plugs, coil, rotor/cap, wires, this is a reman engine with 20,000 miles on it, lifters are ticking real bad on rt. front, I think from the backfiring. whats is going on??

It all started when my starter went out. After replacing and putting proper shims, i shut down and restarted the truck about 6 times and then when i was just about to shut it off and take it off the jack, it just died. The truck hasn't started since. It fired when i poured a small amout of gas in. And my "mechanically inclined" buddies told me it must be injector or the filter, i replaced both, and now i found out i need to bleed the lines after replacing injector but i cant find one!?! 4 Cyl(e)<-8th VIN # SIngle Injection engine. Can anyone please help me out this is my only vehicle =(