Close

1993 Chevrolet Lumina Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
OBD code 35. I have already replaced the IAC, this seemed to work for a few days. Now, the code 35 is showing again and it idles extremely high. When I start the car with the IAC disconnected, there is no change. I can hear a vacuum leak, but, can't find it. Any suggestions?
if not how do the coils come off
so when im driving the car it drives good but when i get to a stop light or stop sign the car sputters and the car sounds like it wants to shut off. the rpms bounce at 500 and some time drops to 400 when at a stop.
and when the the rpm gauge drops the dash lights dim a little.
i replaced the IAC sensor, cleaned the throttle body, did a idle reset, put some injector cleaner in, and problem is still there. if anyone has any ideas PLEASE HELP
when im driving the car its good but when i stop at a traffic light, the idle rpm's will drop to 500 then shut off. but if i hold the brake and put a little pressure on the gas pedal the car stays on.and when i got it home i let it idle for a little with it still in drive and it was fine, but the rpm gauge was bouncing just a little, like it wanted to die. I did alternator check(good) load test on battery(good), and the spark plugs look good also. so what could it be?
I have a 93 chevy lumina the check engine light came on someone told I needed a tune up. Well before I could do it the car started then died out now it won't start. It will crank but not fire I recharged the battery got the spark plugs n wires oil change. Nothin now I was told that the engine module could b bad. I cant go to the shop one it doesn't drive n for two they said they only check when the check engine light comes on not the service light. So I need to know how I could check myself if one of the coils r bad.
when I stopped the engine causes the car to lunge and will die also will not idle
and its leaking transmission fluid.
i have brand new dogbone engine mounts and i was wondering if i need it our not. i was told its a rubber piece to screw onto the mount i don't know for sure
After the flood it ran for two days then it stopped running.
the battery light, oil & coolant light come on when the key is turned to Aux but when I start the car all lights turn off and do not come back on, does that mean my car is ok ? I just want to know if there is something wrong with the car or engine will the light(s) come on and stay on even when I'm driving ?
but then started dying when stopping,, i changed spark plugs and that made it worse
I got hit by some lady today on the drivers side - I need to know the basic break down of the pieces attached to the tire - it appears that she bent the piece attached to it causing my tire to lean in some at the top. Is this an individual piece I could take off and replace, or is it something more? it appears to be just the piece attached to the tire that is bent the axle is fine. If you know anything about this - the repair - or price any help would be greatly appreciated!
I think it is calipers and rotors in the front and drums and shoes in the rear is there anyway to tell which set is causing the pedal to pulsate ?
I want to convert my ac. my car is not making cold air when I turn on the ac..it's blowing, so i know it's not the compressor.
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.