Close

1991 Chevrolet Camaro Questions

Get answers to questions about your 1991 Chevrolet Camaro at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
17
questions

It's getting fire and fuel but when I go to crank it it just whoops like crazy and dumps a lot of gas.

That price is awfully high... Is there a better solution?

ll I have a 97 Camaro v8 Z28. the car won't start the lights the radio everything comes on but the car it might be the. I dont konw what it could be

I HAVE REPLACED THE IDLE AIR VALVE, TPS, AND WENT THROUGH THE STEPS OUTLINED IN THE MANUAL TO RESET THE IDLE BUT IT STILL DOES NOT ALWAYS IDLE THE SAME. ONE TIME IT WILL IDLE RIGHT THE NEXT TIME IT IDLES TOO FAST, THEN TOO SLOW. SOMETIMES TOO ROUGH.
I TRIED TO CLEAN OUT THE THROTTLE PLATES BUT MAY NOT HAVE DONE A GOOD ENOUGH JOB. THANKS
THANKS FOR YOUR HELP.

can you tell me what is going on

labor only

new install never had rear bar before.

1 hr.@ $100. is that a fair price?

I'm told 3hours shop time. @ $100 an hour. Is that a fair price? plus $30.00 for gaskets. $330.00 Total

Well, I reinsured and retagged, now I want to drive it. Before I parked it, I had no problems at all. Now, when I start the car, it fires right up... no problem at all. But after 2 or 3 minutes of running, whether at idle or driving, the car dies. It's like I have a dead battery. No power at all, no radio, lights, nothing. Then, about 5 or 10 minutes later everything works again (I have full power) and it starts right up and drives fine. I have NO idea what is going on. Computer problem?

So to recap: Start car, dies and have no power.
Power restored several minutes later and runs fine. Then loses power.

The engine will turn and turn but won't crank i have already replaced the ECM and it still acts the same. but if i take out the number 1 spark plug it will crank and run and drive for about 5 minutes and shut down again. any help?

When my car is started the heater does not heat. After the car is on for 5 min. OR more the heater still does not heat. There is no heat blown through the air vents NOR the windows defrost vents. Occurs all the time!

gas leaked all under the rear, under the gas tank area.this happened after allmost filling the tank and was losing rpms before refilling tank,thought it was out of gas