1990 Toyota Pickup Q&A

1990 Toyota Pickup Question: Won't start...only clicks

truck 1989 toy pup v6 3. new engine,battery,starter.bat.terminals and new relay. Battery holds charge, terminals are tight and checked for loose cables and still don't know when I'll be left stranded. -
Answer 1
do you have new plugs and wires? any spark on? -
Comment 1
Thanks for your answer ebans. my problems only occurs on an infrequent basis,for the most part it starts fine and only once in a while when I least expect it will just "click". Plugs are fairly new, wires are a little old. I would think that the starter will turn the engine before it gets to the plugs. (?) I also think that there is spark because i can start the engine and go more often than not. Thanks again. -
Answer 2
Neutral safety or ignition switch? -
Comment 1
Can you tell me more about neutral safety? Does it apply to both auto and standard? The ignition assembly is my next step. Thank you. -
Comment 2
NEUTRAL SAFETY IS ON BOTH. MANUAL TRANS , IT WOULD BE A SWITCH ON THE CLUTCH PEDAL/BRACKET. ON AUTO, IT WOULD BE PART OF THE GEAR/RANGE SELECTOR SWITCH. WHEN IT ACTS UP , CHECK FOR SIGNAL TO STARTER SOLENOID , IF NO SIGNAL TEST FOR POWER FROM SWITCH AS IT APPLIES TO YOUR VEHICLE.AUTO. TRANS , SELECTOR SHOULD BE IN PARK OR NEUTRAL , TRY WIGGLING THE SELECTOR LEVER WHEN IT ACTS UP, IF IT'S AUTO. -
Answer 3
you missed something...click means ignition is okay...re-check battery, terminals, cable and starter. -
Comment 1
your..I have a new battery (lights, horn etc. okay). Terminals are new. Also replaced starter twice. I do need to go over every inch of the cable.. Thanks for your info. -
Comment 2
Okay "G"nome, You say you replaced ALL those parts and your starter still clicks...ONE question...Is ALL 12.6V going to your starter? If you are not getting all 12.6V find out why. (EVEN IF YOU HAVE TO CHECK EVERY SINGLE INCH OF WIRE AND CABLE!)..... IF ALL 12.6V IS GOING TO YOUR STARTER...YOUR STARTER IS BAD...that is all there is to it. I hope you find this out when you are already STRANDED! -
Comment 3
WHY so angry? -
Comment 4
Not angry, just being blunt.....nome is saying that he changed the battery, terminals, cable and starter twice and still wonders why it just "clicks" sometimes...and gave me lip about "if he has to go over every inch of cable". I told him if 12.6V is going to his starter, then his starter is bad...if less than 12.6V to his starter...he has to check everything AGAIN cause he missed something. -
Comment 5
NOW if only 'nome' would let us know who and what actually fixed it. ........Wonder if it was fixed by a "H"obbit? -
Comment 6
For sure I'll post the final results. Thanks -
Comment 7
Thank you for responding , and we would definitely appreciate knowing the results , even if it's to say it's fixed and ziptie12 is an idiot! -