wont start on 2004 Chevrolet Aveo

yes i was driving my car this morning and i starting to hear i kliking noise in the right front of the car i made it home but try to go somewere later and it din,t start i turn the engine key and it sound like is going to start but it does not can somebody might tell me what it could be

by in Seabrook, TX on January 22, 2010
3 answers
ANSWER by on January 29, 2010
need to check for spark at the plugs. how many miles are on your car? did you have the timing belt replaced yet?
1 person likes thisFlag inappropiateReply
ANSWER by on March 17, 2010
I had the same thing happen to me about a yr ago. I took it to a mech. They said it was a (I think) starting sensor? It may have another name, but it was some sort of sensor. I hope that helps.
1 person likes thisFlag inappropiateReply
ANSWER by on August 11, 2010
I just had this issue happen to me about a month ago and luckily I have a good warranty with my auto loan dealer, but I had to replace the pistons, valves, spark plugs, and some other items that were involved in the same function it ended uo costing over $2500.
2 people like thisFlag inappropiateReply
Related Items:
i have a 2004 chevy aveo, auto, and it wont start it cranks over but wont start i changed the fuel pump, ecu, fuel pressure regulator, coil paks...
Car wont start no antifreeze
If there is 1 or 2? And what else may not allow a code reader to link and car won't start.
Occurs at randomly. Usually at road speed 60 to 63 for me. Has been going on for about 6 weeks. Has occurred about 9 times. Last time was working I stopped at a store came out to go and it was dead.