Wiper Motor on 2000 Mercedes-Benz C230

I have a 2000 C230 Kompressor with wiper problems. When I turn on the wipers, the wipers will start from the driver side of the car and then stop on the far passenger side. I have added white lithium grease (learned it from a mechanic) to the wipers, cleaned the windshield and other things but have had no luck so far. One thing I have not done is remove the wiper cover and add additional white lithium grease to it. Any suggestions on what may be the problem, how to remove the wiper cover piece or anything. If it helps, the temperature outside is about 25 degrees and I thought that my be part of the problem. Any help to prevent spending $500 - $600 for a new motor would be greatly appreciated.

by in Conshohocken, PA on January 02, 2010
2 answers
ANSWER by on January 16, 2010
This sounds like a motor problem, is that what you ended up finding?
ANSWER by on March 05, 2011
Too bad he didn't remove the cover and apply more lube to the piston. That's what it took to fix mine.
Related Items:
What would be the estimated cost to put in a new wiper motor?
the wiper does not move at all but can hear the motor.
My windshield washer fluid sprayer is not working. When you push in the blinker spray switch. The wipers do not move nor does water come out. The windshield wipers work fine otherwise.
The motor sounds like it is working but wiper is stuck on left side. When manually moved towards the center the motor takes over but gets stuck again on the left side. I have already greased vert...
The wipers were worked on only to find out the wiper motor and the switch were fine. It was the hydraulic arm. It was after all was put back together th...