» » »

Chevrolet Q&A

Ask Your Question

2001 Chevrolet Lumina Question: Windshield washer pump not working

 

Question

rzblumina, Syracuse, NY, March 01, 2010, 17:05
 Rookie

Replaced the pump, still not working. Is there a fuse that may need replacing and where is it located?

2 Answers
Flag This
  • Medium-star Best Answer
    patrick mannion from Greg Solow's Engine Room, March 01, 2010, 22:20
    Profile_thumbnail
     Master

    Fuse 29 (25 Amp) protects both wipers and washer circuit so if wipers work fuse is OK. Red wire at pump brings power dark blue supplies ground to operate the pump, problem may be in the wiring or at the switch itself. You will need a good wiring diagram to trace the circuit. Autozone have some popular workshop manuals for free on line once you register (for free) on their website http://bit.ly/autozone_repair_info .There is a company that independent auto repair shops "buy" their information from that offer a very reasonable service to do it yourselvers. You get a one year subscription to year make and model specific repair procedures, service bulletins, component locations, wiring diagrams ect.... great quality information same as the professionals have ,much better than generic workshop manuals from parts stores, much cheaper than the factory manual. http://bit.ly/alldata_repair_manuals or try http://bit.ly/mitchell_repair_manuals_online and get an online repair manual subscription.

    Reply
    Flag This
  • Answer #2

    Visitor, March 02, 2010, 08:33

    When you are replacing parts without knowing the exact cause its generally gonna cost you a ton more than just bringing it to the shop where they have the right diagnostic equipment.

    Flag This
  • Reply

    rzblumina, March 02, 2010, 09:43
     Rookie

    Thank you autotechpat, motor and pump all new, we were questioning the fuse....will check the wiring next. Diagnostics cost me $90 last time I went in.... Should come to my house for that much money!

    Reply
    Flag This