Why will my 88- Mustang GT only run with starting fluid in the throttle body???? on 1990 Ford Mustang GT

Car started to sputter, then finally just wouldn't run. Checked for fuel pump running it was but the pressure was only about 20psi. I replaced the fuel pump, strainer, and fuel filter. I also blew out the fuel lines and emptied the tank of old gas. I added 5gal fresh gas opened the fuel rail and ran pump until new gas came out. engine turns over with not atempt to start. Checked for Injector pulse with node light tested ok. checked for spark tested ok. If you spay starting fluid into the throttle body it starts right up and idles good until it uses the fluid then shuts off.

by in Laurens, SC on September 29, 2012
2 answers 3 comments
ANSWER by on September 29, 2012
could be a defective fuel pump recheck your fuel pressure again
COMMENT by on September 30, 2012
I checked, the new fuel pump is coming on, and I get 40psi with the key on. Haynes manual says fuel pressure should be 30-45 psi. I'm still focused on the fuel being the problem, because it runs good and starts so fast with the starting fluid. WHat else should I be doing???????????
COMMENT by on September 30, 2012
scan test for codes it could be a tps
COMMENT by on October 03, 2012
MAKE SURE IT IS GETTING GOOD FRESH GAS!!! MAY BE SOME JUNK STILL THERE SOMEWHERE. GOT A RANGER IN THE SHOP NOW SAME DEAL CAUGHT SOME GAS IN CLEAR BOTTLE, HALF JUNK!!! LOOKED LIKE OLD MILK MIXED WITH ORANGE JUICE. I GOT CORRECT FUEL PSI SPARK AND PULSE RUNS ON SPRAY GOOD BUT IT AIN'T GOING TO RUN ON THIS CRAP. I KNOW YOU SAID FRESH GAS AND ALL BUT STILL CHECK IT AGAIN, I WASTED A LOT OF TIME ON THIS ONE!! CUSTOMER SAID NO WAY BUT THERE IT IS.
ANSWER by on October 04, 2012
How are you spraying fluid into throttle body? through mass air flow sensor , or is MAF disconnected?