2003 BMW Z4 Q&A

2003 BMW Z4 Question: WHY MY LIGHTS COME ON

MY TRACTION CONTROL LIGHT, BRAKE LIGHT, LOW PRESSURE LIGHT COME ON WHEN I START MY VEHICLE,BUT GOES OFF WHEN I CUT IT OFF AND RESTART IT. -
Answer 1
Possibly low battery/crank voltage. Best to have the fault code memory checked by your nearest BMW dealer or mechanic, which can be located in the "find a shop" tab above. -
Answer 2
I have an 06 and the exact same thing is happening right now on mine. Also the sub amp cuts out at higher volumes, the windows don't like to roll up and down sometimes automatically, and the car wouldn't even start this morning (cranked and nothing then engine immobilizer came on and I had to pull out the key and put it back in to get it to start finally).. I took it into the shop and they checked the starter, battery, and alternator and they were showing proper voltage and amps.. The only thing I can think of is a problem with the ECU or a short somewhere(fuse, ground, soldering point). -
Comment 1
I have the same problem I changed 2 alternator in 3 weeks , and today my car died on my driveway. If you find what was the problem with your car, please let me know, i am desperate cause I spend a lot of money and the same problem is coming back over and over again. Please send me a mesage to simonamathe@yahoo.com. Thank you. -
Comment 2
Hey I found that my ECU hesitates when I start the vehicle. I figured out that the speaker on the left side of my z4 is shorting and causing the mid-bass woofers to cut out. This had nothing to do with my problem. All I've been doing is before turning over the engine letting the car sit on till the ECU finishes booting up, then starting it. I haven't had the 3 lights come on again in the past few days so I'm not sure what the deal is with it. If it happens again I'll post again. Things I've done since it stopped doing it: Cleaned the wheels, took off the front bumper and adjusted the front headlights cause they were off center, put front bumper back on. Not sure if doing any of this helped anything but I wouldn't think so unless a sensor was dirty or malfunctioning near these areas. -
Comment 3
Well I finally got over to BMW and it was the ignition system. They said it was shorting. Works perfectly now that they replaced it. Idk how much it was cause it was under an extended warranty. -