Why is the front A/C not working? There is a leak under the passenger tire. on 1999 Chrysler Town & Country

I recently took my 99 Town and Country minivan to get the front break pads and rotor done and also got an oil change. When I got it back, I noticed that the front A/C wasn't working. It's releasing cool air, but not much and when I try to increase it, it doesn't work. The back A/C works. Also when the car is parked, I noticed a puddle under the tire of the passenger side. I also noticed a horrible smell after I park. I tried to take it back to the mechanic but they told me they didn't do anything wrong and their repair has nothing to do with the A/C. Upon research, I think it could be the water pump or some A/C tubes are blocked or leaking? Or does it have to do with the coolant. Finally, would this have anything to do with what the mechanic did when he fixed my breaks and changed my oil?

by in Cerritos, CA on October 18, 2013
2 answers 1 comment
ANSWER by on October 18, 2013
Not sure what the puddle is. To answer the a/c question, if your rear a/c is working, should have no Freon leak. It's all 1 system. The front not working could be many possibilities, have a second party inspect it for you to be sure.
ANSWER by on October 18, 2013
The A/C sounds like you might have an issue with the blower inside the vehicle. when you say you turn it up does that mean you turn the fan speed up and it doesn't blow any faster?? The puddle by the right front tire....is it clear water or does it have a color??? We would be more than happy to inspect the vehicle at no cost to you and let you know what is wrong. It would be very hard to tell you if it had anything to do with the oil change or brakes without inspecting the vehicle. Feel free to give ua a call at 562-802-1332. Thank You
1 person likes thisFlag inappropiate
COMMENT by on October 18, 2013
Cool I like it; ATTA BOY