Why, After about 10min of driving my alero starts to skip, then shut off. on 2003 Oldsmobile Alero

My alero will drive for about 10min or so then it will begin to skip, almost as if the Rpms are revving then stopping, then my car dies completely. After about 3-10min my car will crank back up, drive alittle and repeat the process. What can be causing this? I have already changed the fuel filter, firestone could not locate the issue, they are telling me that I need to take it to gm bc it might be my computer. Any ideas?

by in Columbia, SC on May 03, 2014
1 answer 3 comments
ANSWER by on May 03, 2014
Put a fuel pressure gauge on it and drive it to see if fuel pressure stops during or before shut off.
COMMENT by on May 03, 2014
Well firestone did a diagnostic on it, would they not do that themselves during the diagnostic you think? And what do you think it is if it shuts off after and what do you think it is if it shuts off before?
COMMENT by on May 03, 2014
Firestone said that my computer itself is not responding. It is giving off no codes that can be used to identify the problem. Is my only option to go to gm?
COMMENT by on May 03, 2014
No you need a qualified technician, besides Firestone to find the issue. Firestone in your area apparently does not have a qualified person or experienced people to diagnose a drivability problem. The computer will not set a code if the fuel pump fails, and other drivability issues as well. The Technician has to find the problem, sounds like they are part changers.