» » »

Chevrolet Q&A

Ask Your Question

2007 Chevrolet Equinox Question: when transmission is shifted to drive will not pull, if shifted to low will pull

 

Question

ikejr, Jonesville, NC, July 05, 2012, 12:28
 Rookie

vehicle has 70000 mi.

2 Answers
Flag This
  • Answer #1

    Greg's Orange Auto (12192 Answers) , Orange, CA - (714) 361-9386
    globalhelper July 05, 2012, 12:52
     Master

    POSS INTERNAL ISSUE GET A FREE EST AND DIAG FROM AMMCO AND POST CODES IF AVAIL.

    Flag This
  • Reply

    pushrod, July 05, 2012, 14:51
    Profile_thumbnail
     Master

    Have a simple CO test done on the cooling system! This will tell if there is
    a problem with the heads or gaskets.(sorry wrong answer for this question)

    Reply
    Flag This
  • Answer #2

    pushrod July 05, 2012, 14:46
    Profile_thumbnail
     Master

    Have the linkage and adjustments checked. Does reverse seem to be ok?
    Does park work ok ect. Low & reverse are on the same set of clutches
    both should work. If not CHECK the linkage.

    Flag This
  • Reply

    ikejr, July 05, 2012, 15:12
     Rookie

    low and rev work

    Flag This
  • Reply

    pushrod, July 05, 2012, 15:19
    Profile_thumbnail
     Master

    Does the car take off ok in drive and shift into netural on its own? In other words
    do you have to shift to low to make it even move?

    Flag This
  • Reply

    ikejr, July 05, 2012, 15:25
     Rookie

    yes have put in low to get it to move then it will shift to low2 and drive

    Flag This
  • Reply

    pushrod, July 05, 2012, 15:48
    Profile_thumbnail
     Master

    I still think you have a linkage or linkage adjustment problem!

    Flag This
  • Reply

    ikejr, July 05, 2012, 16:45
     Rookie

    thanks headed to dealership

    Reply
    Flag This