when I'm going 0-25 in a parking lot I sound like a popcorn machine. WHY? on 2000 Chevrolet S10

I have had struts, shocks, tire bar,work done on it the noise only appeared after new brakes and the the above things were done. They have had my truck for 3 months they hear it but don't know what it is. Can someone help me? it doesn't happen when it's 30degree or colder only in warm weather.

by in Wheeling, IL on April 03, 2013
2 answers 2 comments
ANSWER by on April 03, 2013
seek a 2nd opinion and tell them the results and let them pay the diag fee
COMMENT by on April 03, 2013
Have gone to 3 different places and no one knows what the problem is. this has been going on for a year now but like I said only when it's warm outside. Last night I got an oil change and they said something about either the struts or shocks, something about cutting or grinding off the factory rivets and lowers and press them though something and borrowing the spring compressor replace both upper and lowers. Now what that means I have no clue cause I don't know what piece they are talking about. But they said they got the answer on one of these web-sites. Any Ideas if this guess is correct of what piece they are referring too??
ANSWER by on April 03, 2013
When does it do it exactly, what actions are you making, accel, decel, just driving straight, turning, braking or what? Auto. or man. trans.? Wont do it on a lift running gear? U-joints ok? Lot more info. needed! Maybe more than you can give but try. We will too!
COMMENT by on April 03, 2013
OK AS OF 4-3-13 the below is correct with items that were done on the truck. I am just driving straight it doesn't happen when I am accel just going 30 mph and lower and it's warm outside. I had no noise all winter long this week-end it was 40 and I was popping all over the place. i have a Manual trans. all items done on the truck are: tie bars,bushings strut and shock brakes greasing of ball bearings but this all started when they did the brakes and they the other stuff with it. Never had any noise prior to those things being done. They have checked and rechecked all work done and just can't find the issue. Someone at the Jiffy Lube oil place said something about the shocks or struts not being placed correctly and that something about cutting or grinding off the factory rivets and lowers and press them though something and borrowing the spring compressor replace both upper and lowers. Oh and the only people who have ever worked on my truck are from the Chevy dealership. they don't know what lift running gear is but all joints are perfect accordoing to them. PLEASE CAN SOMEONE GIVE ME IDEAS AS TO WHAT THE PROBLEM IS! PLEASE this is driving me crazy!!!