Mercedes-Benz Q&A

Ask Your Question

2006 Mercedes-Benz C280 4MATIC Question: wheel noise in tight slow turns

 

Question

farmedout, Middle Grove, NY, August 07, 2010, 16:20
 Rookie

The car makes noises similar to a four wheel drive being turn tight on dry payment. The car is a c280 4matic, is this a big problem?

3 Answers
Flag This
  • Answer #1

    patrick mannion from Greg Solow's Engine Room, August 07, 2010, 16:26
    Profile_thumbnail
     Master

    Its hard to comment on a noise without being able to hear it. I presume its not a clicking sound due to a worn axle CV joint, or a brake or wheel bearing issue. I am not familiar with Mercedes but I know Honda use a special oil in there 4WD if the wrong oil is used the car "chatter" when taking a turn. Have it checked out, if the differential/transfer box oil hasn't be changed it may be a good idea to change the fluids.

    Flag This
  • Reply

    farmedout, August 11, 2010, 23:21
     Rookie

    I think I've TS'd this down to a bad Flex disc. I will know more tomorrow. If not... I will definitely check into the box oil. Thanks for your suggestion.

    Flag This
  • Reply

    Visitor, June 16, 2011, 20:09

    I have th same problem did you find out what was exactly the problem
    Thank you

    Reply
    Flag This
  • Answer #2

    August 11, 2010, 11:52
    Profile_thumbnail
     Journeyman

    If the noise is a chattering/vibration from the center of the vehicle, it's most likely a problem with the transfer case. Transfer case issues are a fairly common problem on C and E class vehicles. Some times flushing and changing the fluid can solve the issue but usually the transfer case will need replacement.

    Flag This
  • Reply

    farmedout, August 11, 2010, 23:21
     Rookie

    I'll be looking at the flex disc tomorrow. Sure hope it's not the TC. The car drives great on the road, only acts up when trying to park. Thank you for your input !

    Reply
    Flag This
  • Answer #3

    October 13, 2013, 10:42
     Rookie

    I have a 2006 C280 and had a similar problem. After flushing and changing the transfer case fluid 3 times they finally changed the transfer case. All is well now.

    Reply
    Flag This