what is a trans sensor on 2004 Oldsmobile Alero

what is a trans sensor and where is it located. 2004 olds alero sometimes doesnt start in park but after jiggling or moving the gear shift from park down and back to park will start in neutral sometimes in park . some one suggest possible trans sensor is going bad. need to know where it is located. and what it is.

by in Pahrump, NV on February 08, 2013
1 answer 2 comments
ANSWER by on February 08, 2013
maybe it is the neutral safety switch
COMMENT by on February 09, 2013
Nope already put a new one in .. that is what we initially thought it was.. a hundred and forty dollar part .. new spark plugs quit the miss and the stalling while going 55 but it still does not start sometimes (not as often) seems like when it is warm out is when it doesn't start.. don/t know if that is a coincidence. thank you
COMMENT by on February 09, 2013
Nope already put a new one in .. that is what we initially thought it was.. a hundred and forty dollar part .. new spark plugs quit the miss and the stalling while going 55 but it still does not start sometimes (not as often) seems like when it is warm out is when it doesn't start.. don/t know if that is a coincidence. thank you oh we also replaced the solenoid . this could get expensive. We did a scan before the spark plugs were changed and it said catalytic converter or oxygen sensor. But the check engine light does not come on anymore since we changed the spark plugs and it is no longer missing.
Related Items:
If I put it in neutral it will start sometime if park fails . If that doesnt work I take it from park to 3rd a couple of times or jiggle the gear shift ( it is automatic) it will start.If the car i...
My tranny shifts fine in all gears and when thorttle down it goes fine but when i am at a cruze speed the tranny slide in and out of gear but if i put gas to it she will go into gear and go. doesnt...