Chevrolet Q&A

Ask Your Question

2002 Chevrolet Trailblazer Question: What do I need to do if my oil pump isn't pumping after timing chain replacement

 

Question

Danjr, Chandler, AZ, August 26, 2012, 23:13
 Rookie

Runs but sounds like it needs oil

3 Answers
Flag This
  • Answer #1

    pushrod August 27, 2012, 04:35
    Profile_thumbnail
     Master

    CHECK OIL PRESS. WITH TEST GUAGE. WHO REPLACED CHAIN AND WHAT ELSE WAS REPLACED? COMPONET KIT?

    Flag This
  • Reply

    Danjr, August 27, 2012, 06:00
     Rookie

    All gears and tensioner

    Flag This
  • Reply

    pushrod, August 27, 2012, 08:27
    Profile_thumbnail
     Master

    HAD ONE IN SHOP CUSTOMER SAID NO OIL PRESS. TURNS OUT THE
    GUAGE WAS DEFECT. THAT IS WHY I SAY HAVE PRESS. CHECKED WITH
    MAN. TEST GUAGE. THE NOISE COULD BE PROBLEM WITH PARTS INSTALLED.

    Reply
    Flag This
  • Answer #2

    Greg's Orange Auto (13255 Answers) , Orange, CA - (714) 361-9386
    globalhelper August 27, 2012, 05:58
     Master

    SEEK HELP FROM HERE ON SOMETHING MAY BE WRONG IF YOU DIDN'T HAVE THIS ISSUE B4

    Reply
    Flag This
  • Answer #3

    ziptie12 August 28, 2012, 08:11
     Master

    Looked up on-line parts info- shows both a 'primary' chain and a 'balance shaft' chain and tensioner ?? if so were both replaced? did you do it yourself , or a shop? If yourself , was there tension on the chain(s) after assembly -Looks like they are hydraulically operated =no sealant or gasket between the tensioner and block, may obstruct oil flow? Just thoughts not especially familiar with that engine.

    Reply
    Flag This