What can I do to fix this problem on 1999 Ford Expedition

Got a PO353, PO356,PO358 after changing all Spark Plugs and all Coil on Plugs, also getting misfire when gas pedal is released Starts up fine Checked connects look okay Checked spark plugs look okay Checked wiring

by in El Paso, TX on April 04, 2013
1 answer 1 comment
ANSWER by on April 04, 2013
rec. fuel system clean. ethanol treatment to 1 tank premium fuel. get fuel running through clean to eliminate fouled injectors as possibility.
COMMENT by on April 04, 2013
I also cleaned tank and lines, also new injectors,new EGR Valve, Trottle position sensor, EGR Position sensor, ICV what else can be done
Related Items:
dropped off vehicle to shop and engine running fine on all 8 cylinders, they repaired what was supposed to be done and when i went to pick up, engine only running on 6 cylinders. they said it would...
Vehicle didn't have a misfire just a bad coil in #8, so I decided to replace all Spark Plugs and Coils, Trottle position sensor,EGR pressure Feedback sensor,EGR valve,Idle Control valve after all t...
Just started leaking out of on where. ..how much is this going to cost me and can I do it my self..
ive heard tapping and putting an insert in the front plugs can be succesful, but that the back to are risky and maybe impossible to do while the heads are on the car.even with an expensive repair k...
my ford has been stalling for about 2 yrs now. they can never figure it out, started out while i was driving, it would just stall, kind of like flat line, then it started while i was at a stop lig...

Related Content