» » »

Ford Q&A

Ask Your Question

1997 Ford Explorer Question: water is leaking from the motor on passenger side what is wrong ?

 

Question

sherriem, 4.0L V6, Springfield, MO, January 06, 2014, 12:56
 Rookie

after i got it cranked i heard a pop

1 Answer
Flag This
  • Answer #1

    pushrod January 06, 2014, 14:37
    Profile_thumbnail
     Master

    Plenty of ANTIFREEZE in the cooling system?

    Flag This
  • Reply

    sherriem, January 06, 2014, 14:43
     Rookie

    i put more n but it just runs out too.

    Flag This
  • Reply

    pushrod, January 06, 2014, 21:55
    Profile_thumbnail
     Master

    I bet it does. It will until it's fixed! What i ment was DID the engine have a sufficient amount of ANTIFREEZE in it to prevent freezing in these cold temptures we have had lately?? Hopefully it's just a heater hose or something simple and not a cracked engine block. Have a mechanic come have a look or tow it to one for inspection. Good luck with this.

    Flag This
  • Reply

    sherriem, January 07, 2014, 17:50
     Rookie

    it was a freeze plug...thanks

    Flag This
  • Reply

    pushrod, January 07, 2014, 17:56
    Profile_thumbnail
     Master

    That is good! I had one today that did not get that lucky! Busted the block. Glad to hear you found the problem.

    Flag This
  • Reply

    sherriem, January 07, 2014, 17:57
     Rookie

    thanks

    Flag This
  • Reply

    pushrod, January 07, 2014, 18:05
    Profile_thumbnail
     Master

    Sure.

    Reply
    Flag This