2000 Volvo S40 Questions

Unanswered 2000 Volvo S40 Questions

Ask a Question
View:RecentAnsweredUnanswered
My brother brought me his s40 and said it has no reverse and wanted me to check it out. I opened up the trans and it smelled like gear oil so I asked him about it and he said he put gear oil in the front differential....
I have change the new thermostat, new radiator (it had a leak before). Can anyone help me out? I have to fix 3 code and bring the car back for emissions Test again in 60 days. Do I have to change MAP sensor? And ...
turn car off and started it back up no sound
Check engine light came on and flashing arrow
I have tried to have my car pass DMV inspection and it has failed five times. I took my car to the dealer to have it ready for inspection. I paid $5,000 in repairs that they said were needed to pass inspection and it ...
Please my volvo s40 is not too fine, Whenever i want to move i make sure i press the throttle well to make the engine high befor moving sometimes when you press the throttle it will just be idlling as if you never eve...
timing belt was allegedly changed recently as well as the sprocket and water pump .. also, i took it to get the code read to one place and they said the ODB2 connection does NOT work?!! meanwhile the place I got it fr...
the front right passenger side makes a really loud grinding/squeaky noise when turning the wheels back and forth regardless if the car is moving or not... kinda like a really loud squeaking door hinge
Sounds like something is still spinning / running - it is around the a/c accumulator area . Can only stop the sound if I disconnect the battery . I put a screw driver on to the accumulator & sounds like it is it ???
I have a 2000 Volvo S40 1.9L Turbo that I recently bought. We had an issue with getting it running, but now that it is running we have another problem. The car will run and idle perfectly but as soon as you put the ca...
I have a 2000 Volvo S40 1.9L Turbo that I recently bought. We had an issue with getting it running, but now that it is running we have another problem. The car will run and idle perfectly but as soon as you put the ca...
my label for park, drive, etc fell into the console. I thought if I removed the boot cover I could get into there. Or do you know how to remove the console