Close

1995 Volkswagen EuroVan Questions

Get answers to questions about your 1995 Volkswagen EuroVan at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
11
questions

The check engine light has given me error code 00515. The problem has been identified as a bad ECM module, resulting from the replacement of my exhaust system (this is what I was told by the shop that did the damage). Does this make sense? Looking for a replacement module or repair of my current ECM. Part # 023906024A

I need to replace the thermostat in the 1995 Volkswagen Rialta 2.5 liter engine. Will it be the same as the 1995 2.5L Eurovan?

It's in a 1995 Winnabago Rialta. Manufacturer dat is 4/1994.

Everything works great, but transmission makes noise that appears to be normal. Oil advances may provide a quieter ride.

after getting gas, I pushed the trip mileage button & suddenly the speedometer didn't work at all. Is this expensive to fix?

It will start well, runs and idles well, then dies. Got me scratching my head!

the oil light comes on when the engine is running ok

I removed the battery and the top cover of the ECU. I tried to pull off the plug unit but didn't want to force it. I need to get to the contact points and wires that exit the ECU. The former mechanic said that there was 12 volts entering the ECU but only 6-7 volts leaving it which caused my engine missing issues.

Engine missing, a former mechanic solved the problem by cleaning the wires and terminals.

The left signals work. The rights dont. I have checked the right rear bulb. I cant figure out how to get to the back of the front right fixture to check that bulb. How do I get there from here? and is it possibly something else?

With headlights off, eurovan temp gauge gets a false overtemp.
turn headlights on, while rotating dimmer wheel down then up, tachometer operation is directly affected. (dimmer wheel down,tach. works, dimmer wheel up,tach. does not works).
Also dimmer wheel down,get a false overtemp with red blinking overtemp light,dimmer wheel up,temp. gauge creeps back to normal range but tach. drops to zero. correlation of tach. movement is directly affected by dimmer wheel movement.
also, when headlights are on, there is dash area illumination except for all instrument cluster gauges.
I have so far replaced temp sensor, inoperative horns, contact cleaned all fuse/relay plugs. Help please.