Vibration on 1991 Ford Escort

When I accelerate after 40mph I start to get a very bad vibration.When I deccelerate the viberation stops. I have replaced all motor mounts (4) ,front tires & front end aligned & I still have the vibration when I accelerate.

by in Houston, TX on September 25, 2009
2 answers
ANSWER by on September 25, 2009
Hello, This may be due to a bad axle, or more specifically, a binding inner CV joint. They are hard to diagnose because it's hard to look at it and know if it's bad, but that is what I would look at next.
ANSWER by on December 28, 2010
Depending on the noise,mine was the front spolier was loose.
Related Items:
...t was vibrating so loud. Then I shut it harder and it was better but there was still a bit of vibration on the front right side of the car. My landlord looked under the hood and noticed that this t...
...rd Escort 4 door. I just bought the car today - it test drove ok but today there was a strong vibration and shaking on the right passenger side of the car, especially when I brake. I was told it co...
I replaced both axle shafts and lower ball joints,now there is a vibration when i accelerate and a bad banging sound when i turn the wheel or hit a bump,could the front...
when driving an sitting ideal my car vibrates from the engine to the body of the car, an when i start my car,to drive off there's a jerk, 1 mecanic told me it was 1 of my transmission valves but do...
front end vibrates when braking. checked pads and they are still good. stops fine just seems to vibrate and loose when braking over 40mph. not as noticeable at lower speeds.