kbpool

Rookie
40 points
Recent Activity

Question Answered: active suspension not working.
February 25, 2012, 06:32 PM
NEVER HEARD OF A SUSPENSION CONTROL ON THAT CAR
Question Answered: front lower control arms bushing
February 25, 2012, 06:21 PM
DID THEY REPLACE THE STRUT MOUNTS? VERY IMPORTANT.. A LOT OF PEOPLE GET STRUTS REPLACED BUT THE MOUNTS ARE ALSO BAD.. THEY HOLD THE STRUT IN PLACE AT THE TOP.
Question Answered: front brake locks up in drive
February 25, 2012, 06:10 PM
DID YOU MESS WITH THE PISTONS ON THE CALIPER? PUSH THEM BACK OR DAMAGE THE BRAKE HOSE TO THE CALIPER? IT IS NOT GOING TO DO THAT BECAUSE OF AN AXLE.
Question Answered: How can a mechanic claim I have original plugs/wiring harness?
February 25, 2012, 06:02 PM
SOMETIMES OE PARTS ARE MARKED WITH A SLASH OF COLORED PAINT
Question Answered: radiator replacement
February 25, 2012, 05:59 PM
I HAVE TALKED TO ANOTHER OWNER OF A 1992 SC400 THAT HAS GONE THROUGH 3 RADIATORS. I HAVE A RADIATOR WARNING LIGHT THAT COMES ON WHEN I FIRST START MY CAR AND GOES OUT IN 1 MINUTE.. I THINK IT MIGHT BE A SENSOR? BUT AT 157K WHY NOT DO IT TO BE SAFE... DON'T WANT TO DAMAGE OTHER PARTS OF YOUR ENGINE.
Question Asked: electrical
May 23, 2011, 06:40 PM
sometimes my clock changes, and when i use my blinker the radio cuts out for a second. sometimes when i hit the brake the radio cuts out for a second. can see dash lights slightly dim when i hit the brake. doesn't always do this.
No activities found
No activities found
No activities found
Answer Ranks