Rookie

Rookie

35 points

More About Points »

Jmarks79

Schaumburg, IL

jmarks79 has not written a profile yet.

Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Asked: 

My truck was in shop to repair exhaust manifold leak and battery went dead. They left key in ignition. They recharged it but now the trans shifts hard 1st to 2nd.


Flag This
Question Asked: 

So there was a clunk occasionally and discovered the driver side lower ball joint was bad. I replaced the lower control arm with a moog brand. When driving after the replacement now there is a much louder clunk and over ever bump even the smallest bumps?


Flag This
Question Asked: 

I have replaced the surpantine belt and AC belt in Oct and both belt tensioners after the belt didnt work. After i replaced the tensioners the squeek was gone for a month but now this weekend in the morning there is a squeeky belt sound again?


Flag This
Question Asked: 

I had a bad CV on the right side and there was a clicking noise. I changed both CVs this fixed the grinding but not the ticking. I found out hubs where making the clicking noise so I just replaced both hubs. After all this in turns there is a roughness still. Also not sure if its related but over rough pavement the whole truck feels loose.


Flag This
Question Asked: 

It is a 4wd 1500 I 1st had the ticking sound at slow speeds and then a few weeks later a binding and grinding when turning. I replaced both CV axle shafts and the right front was bad. After I installed the new CV's the next day I could hear the ticking again? Teh hub was replaced 2 years ago. Is this a bad CV again or maybe hub or brakes?


Flag This
Answer Ranks