Rookie

Rookie

25 points

More About Points »

Cory93jennings

Louisville, KY

cory93jennings has not written a profile yet.

Recent Activity

Questions & Answers | Problem Reports | Reviews | Comments

Question Asked: 

hi i have a chevy lumina 3.1 engine 1990. it will start fine if it hasn't been running. but after running for thirty minutes, being turned off, then tried to start again, it wont start. Almost as if something is overheated. well i think the problem started after i installed a new radio, I used the radio a few days then it blew a fuse to the (emc or radio fuse i dont remember exactly which fuse was blown) and quit working. the next day i checked the fuses and changed the broken one out it was a 15 for a new one i got from auto zone. the car drove me there fine. i think one place told me there was a short in the starter or the ignition i can not remember which one and i am trying to figure out which one they told me hope you can help. so the car starts fine when it hasnt been running, but when the car has been running for a while and turned off it wont restart. i get the lights to come on but the engine doesnt turn over, it does not make a clicking sound. i wait thirty minutes or so and it will restart if it is in the mid day of 90 degree weather it will take more like an hour before it will restart leading me to think that it is heat related. is there any way to check for a short in the starter or for a bad starter or for a bad solenoid how do i check to see what is exactly wrong with it? also the low coolant light comes on but i took it to the shop yesterday forthat and they said my engine looked great and my coolant system look great and it had fluid in all places it should... idk fan problem? electrical? or starter? they replaced the coolant level sensor but that seemed to be a waste of money. and they seem to not know what they are talking about with my car.


Flag This
Answer Ranks